# CVE-2022-39381: Unchecked Return Value to NULL Pointer Dereference in PDFDocumentHandler.cpp

> Attackers can cause a denial of service in MuhammaraJS by supplying a maliciously crafted PDF file for appending.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Nov 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-rcrx-fpjp-mfrw

## What is CVE-2022-39381?

CVE-2022-39381 is a high-severity vulnerability in julianhille MuhammaraJS, published on 2 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Muhammara is a node module with c/cpp bindings to modify PDF with js for node or electron (based/replacement on/of galkhana/hummusjs). The package muhammara before 2.6.0; all versions of package hummus are vulnerable to Denial of Service (DoS) when supplied with a maliciously crafted PDF file to be appended to another. This issue has been patched in 2.6.0 for muhammara and not at all for hummus. As a workaround, do not process files from untrusted sources.

Weakness: CWE-476 (NULL Pointer Dereference), CWE-690 (Unchecked Return Value to NULL Pointer Dereference)

## Which versions are affected by CVE-2022-39381?

4 open source packages ship an affected version, including hummus and muhammara. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hummus` | npm | All versions | 1.0.111 |
| `hummus` | npm | All versions | 1.0.111 |
| `muhammara` | npm | All versions | 2.6.0 |
| `muhammara` | npm | All versions | 2.6.0 |

Products: Muhammarajs Project Muhammarajs, Pdfhummus Hummusjs.

## How do I fix CVE-2022-39381?

Upgrade hummus to 1.0.111 or later.

## Is CVE-2022-39381 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39381 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39381 and fix it if it is affected.

What it is: CVE-2022-39381 is a high-severity vulnerability in julianhille MuhammaraJS, published on 2 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39381 exists.

Affected packages and fixed versions:
- hummus (npm): affected all versions; fixed in 1.0.111
- hummus (npm): affected all versions; fixed in 1.0.111
- muhammara (npm): affected all versions; fixed in 2.6.0
- muhammara (npm): affected all versions; fixed in 2.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39381/ (Markdown: https://insights.sbomify.com/CVE-2022-39381/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39381
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39381
- OSV: https://osv.dev/vulnerability/CVE-2022-39381

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39381/
Summaries are generated and may contain mistakes; the official description above is the record.
