{"answers":{"affected":"6 open source packages ship an affected version, including fastify-websocket and @fastify/websocket. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-39386 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2022-39386 is a high-severity denial of service vulnerability in fastify-websocket, published on 8 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-39386 and fix it if it is affected.\n\nWhat it is: CVE-2022-39386 is a high-severity denial of service vulnerability in fastify-websocket, published on 8 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-39386 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- fastify-websocket (npm): affected all versions up to 4.3.0; no fix listed\n- fastify-websocket (npm): affected all versions up to 4.3.0; no fix listed\n- @fastify/websocket (npm): affected from 5.0.0; fixed in 5.0.1\n- @fastify/websocket (npm): affected from 5.0.0; fixed in 5.0.1\n- @fastify/websocket (npm): affected from 6.0.0; fixed in 7.1.1\n- @fastify/websocket (npm): affected from 6.0.0; fixed in 7.1.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-39386/ (Markdown: https://insights.sbomify.com/CVE-2022-39386/index.md)","id":"CVE-2022-39386","markdown":"https://insights.sbomify.com/CVE-2022-39386/index.md","name":"CVE-2022-39386","record":{"aliases":["GHSA-4pcg-wr6c-h9cq"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Fastify WebSocket library","requires_auth":"none","summary":"Attackers can crash applications using the deprecated fastify-websocket library by sending malformed packets, requiring an upgrade to patched versions.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"websocket","vendor":"fastify"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-248","name":"Uncaught Exception"}],"description":"@fastify/websocket provides WebSocket support for Fastify. Any application using @fastify/websocket could crash if a specific, malformed packet is sent. All versions of fastify-websocket are also impacted. That module is deprecated, so it will not be patched. This has been patched in version 7.1.1 (fastify v4) and version 5.0.1 (fastify v3). There are currently no known workarounds. However, it should be possible to attach the error handler manually. The recommended path is upgrading to the patched versions.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"fastify-websocket vulnerable to uncaught exception via crash on malformed packet","id":"CVE-2022-39386","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":6,"n_references":1,"next":{"headline":"XWiki OIDC Authenticator vulnerable to OpenID login bypass due to improper authentication","id":"CVE-2022-39387"},"packages":[{"ecosystem":"npm","fixed":["5.0.1"],"introduced":["5.0.0"],"last_affected":[],"package":"@fastify/websocket","purl":null,"source":"GHSA-4pcg-wr6c-h9cq"},{"ecosystem":"npm","fixed":["5.0.1"],"introduced":["5.0.0"],"last_affected":[],"package":"@fastify/websocket","purl":"pkg:npm/%40fastify/websocket","source":"GHSA-4pcg-wr6c-h9cq"},{"ecosystem":"npm","fixed":["7.1.1"],"introduced":["6.0.0"],"last_affected":[],"package":"@fastify/websocket","purl":null,"source":"GHSA-4pcg-wr6c-h9cq"},{"ecosystem":"npm","fixed":["7.1.1"],"introduced":["6.0.0"],"last_affected":[],"package":"@fastify/websocket","purl":"pkg:npm/%40fastify/websocket","source":"GHSA-4pcg-wr6c-h9cq"},{"ecosystem":"npm","fixed":[],"introduced":["0"],"last_affected":["4.3.0"],"package":"fastify-websocket","purl":null,"source":"GHSA-4pcg-wr6c-h9cq"},{"ecosystem":"npm","fixed":[],"introduced":["0"],"last_affected":["4.3.0"],"package":"fastify-websocket","purl":"pkg:npm/fastify-websocket","source":"GHSA-4pcg-wr6c-h9cq"}],"prev":{"headline":"Users erroneously and transparently added to private messages in Discourse","id":"CVE-2022-39385"},"products":["fastify-websocket"],"published":"2022-11-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["fastify"]},"summary":"Attackers can crash applications using the deprecated fastify-websocket library by sending malformed packets, requiring an upgrade to patched versions.","url":"https://insights.sbomify.com/CVE-2022-39386/"}