# CVE-2022-39386: fastify-websocket vulnerable to uncaught exception via crash on malformed packet

> Attackers can crash applications using the deprecated fastify-websocket library by sending malformed packets, requiring an upgrade to patched versions.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Nov 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-4pcg-wr6c-h9cq

## What is CVE-2022-39386?

CVE-2022-39386 is a high-severity denial of service vulnerability in fastify-websocket, published on 8 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

@fastify/websocket provides WebSocket support for Fastify. Any application using @fastify/websocket could crash if a specific, malformed packet is sent. All versions of fastify-websocket are also impacted. That module is deprecated, so it will not be patched. This has been patched in version 7.1.1 (fastify v4) and version 5.0.1 (fastify v3). There are currently no known workarounds. However, it should be possible to attach the error handler manually. The recommended path is upgrading to the patched versions.

Weakness: CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2022-39386?

6 open source packages ship an affected version, including fastify-websocket and @fastify/websocket. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fastify-websocket` | npm | All versions to 4.3.0 | None |
| `fastify-websocket` | npm | All versions to 4.3.0 | None |
| `@fastify/websocket` | npm | From 5.0.0 | 5.0.1 |
| `@fastify/websocket` | npm | From 5.0.0 | 5.0.1 |
| `@fastify/websocket` | npm | From 6.0.0 | 7.1.1 |
| `@fastify/websocket` | npm | From 6.0.0 | 7.1.1 |

Products: Fastify Websocket.

## How do I fix CVE-2022-39386?

Upgrade to a fixed version.

## Is CVE-2022-39386 being exploited?

There is no known exploitation of CVE-2022-39386 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39386 and fix it if it is affected.

What it is: CVE-2022-39386 is a high-severity denial of service vulnerability in fastify-websocket, published on 8 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-39386 in the wild and no public exploit code.

Affected packages and fixed versions:
- fastify-websocket (npm): affected all versions up to 4.3.0; no fix listed
- fastify-websocket (npm): affected all versions up to 4.3.0; no fix listed
- @fastify/websocket (npm): affected from 5.0.0; fixed in 5.0.1
- @fastify/websocket (npm): affected from 5.0.0; fixed in 5.0.1
- @fastify/websocket (npm): affected from 6.0.0; fixed in 7.1.1
- @fastify/websocket (npm): affected from 6.0.0; fixed in 7.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39386/ (Markdown: https://insights.sbomify.com/CVE-2022-39386/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39386
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39386
- OSV: https://osv.dev/vulnerability/CVE-2022-39386

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39386/
Summaries are generated and may contain mistakes; the official description above is the record.
