{"answers":{"affected":"2 open source packages ship an affected version, including org.xwiki.contrib.oidc:oidc-authenticator. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-39387 in the wild and no public exploit code.","fix":"Upgrade org.xwiki.contrib.oidc:oidc-authenticator to 1.29.1 or later.","what":"CVE-2022-39387 is a critical authentication bypass vulnerability in xwiki-contrib oidc, published on 4 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-39387 and fix it if it is affected.\n\nWhat it is: CVE-2022-39387 is a critical authentication bypass vulnerability in xwiki-contrib oidc, published on 4 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-39387 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.xwiki.contrib.oidc:oidc-authenticator (Maven): affected all versions; fixed in 1.29.1\n- org.xwiki.contrib.oidc:oidc-authenticator (Maven): affected all versions; fixed in 1.29.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-39387/ (Markdown: https://insights.sbomify.com/CVE-2022-39387/index.md)","id":"CVE-2022-39387","markdown":"https://insights.sbomify.com/CVE-2022-39387/index.md","name":"CVE-2022-39387","record":{"aliases":["GHSA-m7gv-v8xx-v47w"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"XWiki OIDC plugin","requires_auth":"none","summary":"Attackers can bypass authentication and gain admin privileges by specifying malicious OpenID provider parameters in requests.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"openid_connect","vendor":"xwiki"}],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"XWiki OIDC has various tools to manipulate OpenID Connect protocol in XWiki. Prior to version 1.29.1, even if a wiki has an OpenID provider configured through its xwiki.properties, it is possible to provide a third party provider its details through request parameters. One can then bypass the XWiki authentication altogether by specifying its own provider through the oidc.endpoint.* request parameters (or by using an XWiki-based OpenID provider with oidc.xwikiprovider. With the same approach, one could also provide a specific group mapping through oidc.groups.mapping that would make his user automatically part of the XWikiAdminGroup. This issue has been patched, please upgrade to 1.29.1. There is no workaround, an upgrade of the authenticator is required.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"XWiki OIDC Authenticator vulnerable to OpenID login bypass due to improper authentication","id":"CVE-2022-39387","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"auth_bypass","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Istio may allow identity impersonation if user has localhost access","id":"CVE-2022-39388"},"packages":[{"ecosystem":"Maven","fixed":["1.29.1"],"introduced":["0"],"last_affected":[],"package":"org.xwiki.contrib.oidc:oidc-authenticator","purl":null,"source":"GHSA-m7gv-v8xx-v47w"},{"ecosystem":"Maven","fixed":["1.29.1"],"introduced":["0"],"last_affected":[],"package":"org.xwiki.contrib.oidc:oidc-authenticator","purl":"pkg:maven/org.xwiki.contrib.oidc/oidc-authenticator","source":"GHSA-m7gv-v8xx-v47w"}],"prev":{"headline":"fastify-websocket vulnerable to uncaught exception via crash on malformed packet","id":"CVE-2022-39386"},"products":["oidc"],"published":"2022-11-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["xwiki-contrib"]},"summary":"Attackers can bypass authentication and gain admin privileges by specifying malicious OpenID provider parameters in requests.","url":"https://insights.sbomify.com/CVE-2022-39387/"}