# CVE-2022-39389: Witness Block Parsing DoS Vulnerability in lnd

> Attackers can cause lnd nodes to enter a degraded state, preventing channel openings and on-chain detection, potentially leading to fund loss.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Nov 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-hc82-w9v8-83pr

## What is CVE-2022-39389?

CVE-2022-39389 is a high-severity denial of service vulnerability in lightningnetwork lnd, published on 17 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Lightning Network Daemon (lnd) is an implementation of a lightning bitcoin overlay network node. All lnd nodes before version `v0.15.4` are vulnerable to a block parsing bug that can cause a node to enter a degraded state once encountered. In this degraded state, nodes can continue to make payments and forward HTLCs, and close out channels. Opening channels is prohibited, and also on chain transaction events will be undetected. This can cause loss of funds if a CSV expiry is researched during a breach attempt or a CLTV delta expires forgetting the funds in the HTLC. A patch is available in `lnd` version 0.15.4. Users are advised to upgrade. Users unable to upgrade may use the `lncli updatechanpolicy` RPC call to increase their CLTV value to a very high amount or increase their fee policies. This will prevent nodes from routing through your node, meaning that no pending HTLCs can be present.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2022-39389?

2 open source packages ship an affected version, including github.com/lightningnetwork/lnd. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/lightningnetwork/lnd` | Go | All versions | 0.15.4-beta |
| `github.com/lightningnetwork/lnd` | Go | All versions | 0.15.4-beta |

Products: Btcd Project Btcd, Lightning Network Daemon Project Lightning Network Daemon.

## How do I fix CVE-2022-39389?

Upgrade github.com/lightningnetwork/lnd to 0.15.4-beta or later.

## Is CVE-2022-39389 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39389 exists.

## Other vulnerabilities in lightningnetwork lnd

- [CVE-2022-44797](https://insights.sbomify.com/CVE-2022-44797/): btcd mishandles witness size checking (critical 9.8)
- [CVE-2024-34478](https://insights.sbomify.com/CVE-2024-34478/): btcd susceptible to consensus failures (high 7.5)
- [CVE-2024-38365](https://insights.sbomify.com/CVE-2024-38365/): btcd did not correctly re-implement Bitcoin Core's "FindAndDelete()" functionality (high 7.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39389 and fix it if it is affected.

What it is: CVE-2022-39389 is a high-severity denial of service vulnerability in lightningnetwork lnd, published on 17 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39389 exists.

Affected packages and fixed versions:
- github.com/lightningnetwork/lnd (Go): affected all versions; fixed in 0.15.4-beta
- github.com/lightningnetwork/lnd (Go): affected all versions; fixed in 0.15.4-beta

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39389/ (Markdown: https://insights.sbomify.com/CVE-2022-39389/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39389
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39389
- OSV: https://osv.dev/vulnerability/CVE-2022-39389

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39389/
Summaries are generated and may contain mistakes; the official description above is the record.
