CVE-2022-39395 Vela Insecure Defaults

Critical 9.6 Published Updated

Insecure defaults in Vela CI/CD allow container breakouts and privilege escalation, requiring administrators to upgrade and reconfigure settings.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2022-39395?

CVE-2022-39395 is a critical vulnerability in go-vela server, published on 10 Nov 2022. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Vela is a Pipeline Automation (CI/CD) framework built on Linux container technology written in Golang. In Vela Server and Vela Worker prior to version 0.16.0 and Vela UI prior to version 0.17.0, some default configurations for Vela allow exploitation and container breakouts. Users should upgrade to Server 0.16.0, Worker 0.16.0, and UI 0.17.0 to fix the issue. After upgrading, Vela administrators will need to explicitly change the default settings to configure Vela as desired. Some of the fixes will interrupt existing workflows and will require Vela administrators to modify default settings. However, not applying the patch (or workarounds) will continue existing risk exposure. Some workarounds are available. Vela administrators can adjust the worker's `VELA_RUNTIME_PRIVILEGED_IMAGES` setting to be explicitly empty, leverage the `VELA_REPO_ALLOWLIST` setting on the server component to restrict access to a list of repositories that are allowed to be enabled, and/or audit enabled repositories and disable pull_requests if they are not needed.

Weakness: CWE-269

Which versions are affected by CVE-2022-39395?

6 open source packages ship an affected version, including github.com/go-vela/server and github.com/go-vela/worker. It affects 3 products.

PackageAffectedFixed in
github.com/go-vela/server GoAll versions0.16.0
github.com/go-vela/server GoAll versions0.16.0
github.com/go-vela/server GoAll versions0.16.0
github.com/go-vela/worker GoAll versions0.16.0
github.com/go-vela/worker GoAll versions0.16.0
github.com/go-vela/worker GoAll versions0.16.0

Products include Go-Vela Server, Go-Vela Ui, Go-Vela Worker.

How do I fix CVE-2022-39395?

Upgrade github.com/go-vela/server to 0.16.0 or later.

Is CVE-2022-39395 being exploited?

There is no known exploitation of CVE-2022-39395 in the wild and no public exploit code.

Sources

Also known as GHSA-2w78-ffv6-p46w, GHSA-5m7g-pj8w-7593, GHSA-xf39-98m2-889v, GO-2022-1100.

Is CVE-2022-39395 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free