{"answers":{"affected":"6 open source packages ship an affected version, including github.com/go-vela/server and github.com/go-vela/worker. It affects 3 products.","exploited":"There is no known exploitation of CVE-2022-39395 in the wild and no public exploit code.","fix":"Upgrade github.com/go-vela/server to 0.16.0 or later.","what":"CVE-2022-39395 is a critical vulnerability in go-vela server, published on 10 Nov 2022. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-39395 and fix it if it is affected.\n\nWhat it is: CVE-2022-39395 is a critical vulnerability in go-vela server, published on 10 Nov 2022. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-39395 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/go-vela/server (Go): affected all versions; fixed in 0.16.0\n- github.com/go-vela/server (Go): affected all versions; fixed in 0.16.0\n- github.com/go-vela/server (Go): affected all versions; fixed in 0.16.0\n- github.com/go-vela/worker (Go): affected all versions; fixed in 0.16.0\n- github.com/go-vela/worker (Go): affected all versions; fixed in 0.16.0\n- github.com/go-vela/worker (Go): affected all versions; fixed in 0.16.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-39395/ (Markdown: https://insights.sbomify.com/CVE-2022-39395/index.md)","id":"CVE-2022-39395","markdown":"https://insights.sbomify.com/CVE-2022-39395/index.md","name":"CVE-2022-39395","record":{"aliases":["GHSA-2w78-ffv6-p46w","GHSA-5m7g-pj8w-7593","GHSA-xf39-98m2-889v","GO-2022-1100"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["privilege_escalation","code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Vela CI/CD server","requires_auth":"none","summary":"Insecure defaults in Vela CI/CD allow container breakouts and privilege escalation, requiring administrators to upgrade and reconfigure settings.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"server","vendor":"go-vela"},{"product":"ui","vendor":"go-vela"},{"product":"worker","vendor":"go-vela"}],"cvss":{"score":9.6,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"Vela is a Pipeline Automation (CI/CD) framework built on Linux container technology written in Golang. In Vela Server and Vela Worker prior to version 0.16.0 and Vela UI prior to version 0.17.0, some default configurations for Vela allow exploitation and container breakouts. Users should upgrade to Server 0.16.0, Worker 0.16.0, and UI 0.17.0 to fix the issue. After upgrading, Vela administrators will need to explicitly change the default settings to configure Vela as desired. Some of the fixes will interrupt existing workflows and will require Vela administrators to modify default settings. However, not applying the patch (or workarounds) will continue existing risk exposure. Some workarounds are available. Vela administrators can adjust the worker's `VELA_RUNTIME_PRIVILEGED_IMAGES` setting to be explicitly empty, leverage the `VELA_REPO_ALLOWLIST` setting on the server component to restrict access to a list of repositories that are allowed to be enabled, and/or audit enabled repositories and disable pull_requests if they are not needed.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Vela Insecure Defaults","id":"CVE-2022-39395","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"privilege_escalation","year":"2022"},"n_packages":6,"n_references":10,"next":{"headline":"Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser","id":"CVE-2022-39396"},"packages":[{"ecosystem":"Go","fixed":["0.16.0"],"introduced":["0"],"last_affected":[],"package":"github.com/go-vela/server","purl":null,"source":"GHSA-5m7g-pj8w-7593"},{"ecosystem":"Go","fixed":["0.16.0"],"introduced":["0"],"last_affected":[],"package":"github.com/go-vela/server","purl":"pkg:golang/github.com/go-vela/server","source":"GHSA-5m7g-pj8w-7593"},{"ecosystem":"Go","fixed":["0.16.0"],"introduced":["0"],"last_affected":[],"package":"github.com/go-vela/server","purl":"pkg:golang/github.com/go-vela/server","source":"GO-2022-1100"},{"ecosystem":"Go","fixed":["0.16.0"],"introduced":["0"],"last_affected":[],"package":"github.com/go-vela/worker","purl":null,"source":"GHSA-5m7g-pj8w-7593"},{"ecosystem":"Go","fixed":["0.16.0"],"introduced":["0"],"last_affected":[],"package":"github.com/go-vela/worker","purl":"pkg:golang/github.com/go-vela/worker","source":"GHSA-5m7g-pj8w-7593"},{"ecosystem":"Go","fixed":["0.16.0"],"introduced":["0"],"last_affected":[],"package":"github.com/go-vela/worker","purl":"pkg:golang/github.com/go-vela/worker","source":"GO-2022-1100"}],"prev":{"headline":"wasmtime_trap_code C API function has out of bounds write vulnerability","id":"CVE-2022-39394"},"products":["server"],"published":"2022-11-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["go-vela"]},"summary":"Insecure defaults in Vela CI/CD allow container breakouts and privilege escalation, requiring administrators to upgrade and reconfigure settings.","url":"https://insights.sbomify.com/CVE-2022-39395/"}