# CVE-2022-39395: Vela Insecure Defaults

> Insecure defaults in Vela CI/CD allow container breakouts and privilege escalation, requiring administrators to upgrade and reconfigure settings.

- **Severity:** Critical 9.6 (`CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Nov 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-2w78-ffv6-p46w, GHSA-5m7g-pj8w-7593, GHSA-xf39-98m2-889v, GO-2022-1100

## What is CVE-2022-39395?

CVE-2022-39395 is a critical vulnerability in go-vela server, published on 10 Nov 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Vela is a Pipeline Automation (CI/CD) framework built on Linux container technology written in Golang. In Vela Server and Vela Worker prior to version 0.16.0 and Vela UI prior to version 0.17.0, some default configurations for Vela allow exploitation and container breakouts. Users should upgrade to Server 0.16.0, Worker 0.16.0, and UI 0.17.0 to fix the issue. After upgrading, Vela administrators will need to explicitly change the default settings to configure Vela as desired. Some of the fixes will interrupt existing workflows and will require Vela administrators to modify default settings. However, not applying the patch (or workarounds) will continue existing risk exposure. Some workarounds are available. Vela administrators can adjust the worker's `VELA_RUNTIME_PRIVILEGED_IMAGES` setting to be explicitly empty, leverage the `VELA_REPO_ALLOWLIST` setting on the server component to restrict access to a list of repositories that are allowed to be enabled, and/or audit enabled repositories and disable pull_requests if they are not needed.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2022-39395?

6 open source packages ship an affected version, including github.com/go-vela/server and github.com/go-vela/worker. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/go-vela/server` | Go | All versions | 0.16.0 |
| `github.com/go-vela/server` | Go | All versions | 0.16.0 |
| `github.com/go-vela/server` | Go | All versions | 0.16.0 |
| `github.com/go-vela/worker` | Go | All versions | 0.16.0 |
| `github.com/go-vela/worker` | Go | All versions | 0.16.0 |
| `github.com/go-vela/worker` | Go | All versions | 0.16.0 |

Products: Go-Vela Server, Go-Vela Ui, Go-Vela Worker.

## How do I fix CVE-2022-39395?

Upgrade github.com/go-vela/server to 0.16.0 or later.

## Is CVE-2022-39395 being exploited?

There is no known exploitation of CVE-2022-39395 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39395 and fix it if it is affected.

What it is: CVE-2022-39395 is a critical vulnerability in go-vela server, published on 10 Nov 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-39395 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/go-vela/server (Go): affected all versions; fixed in 0.16.0
- github.com/go-vela/server (Go): affected all versions; fixed in 0.16.0
- github.com/go-vela/server (Go): affected all versions; fixed in 0.16.0
- github.com/go-vela/worker (Go): affected all versions; fixed in 0.16.0
- github.com/go-vela/worker (Go): affected all versions; fixed in 0.16.0
- github.com/go-vela/worker (Go): affected all versions; fixed in 0.16.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39395/ (Markdown: https://insights.sbomify.com/CVE-2022-39395/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39395
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39395
- OSV: https://osv.dev/vulnerability/CVE-2022-39395

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39395/
Summaries are generated and may contain mistakes; the official description above is the record.
