{"answers":{"affected":"3 open source packages ship an affected version, including aliyun-oss-client. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-39397 in the wild and no public exploit code.","fix":"Upgrade aliyun-oss-client to 0.8.1 or later.","what":"CVE-2022-39397 is a medium-severity vulnerability in tu6ge oss-rs, published on 22 Nov 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-39397 and fix it if it is affected.\n\nWhat it is: CVE-2022-39397 is a medium-severity vulnerability in tu6ge oss-rs, published on 22 Nov 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-39397 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- aliyun-oss-client (crates.io): affected all versions; fixed in 0.8.1\n- aliyun-oss-client (crates.io): affected all versions; fixed in 0.8.1\n- aliyun-oss-client (crates.io): affected from 0.0.0-0; fixed in 0.8.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-39397/ (Markdown: https://insights.sbomify.com/CVE-2022-39397/index.md)","id":"CVE-2022-39397","markdown":"https://insights.sbomify.com/CVE-2022-39397/index.md","name":"CVE-2022-39397","record":{"aliases":["GHSA-3w3h-7xgx-grwc","RUSTSEC-2022-0089"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Rust OSS client","requires_auth":"high_privilege","summary":"The aliyun-oss-client library unintentionally discloses sensitive secrets, requiring users to upgrade to the patched version.","user_interaction":"required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"aliyun-oss-client","vendor":"aliyun-oss-client_project"}],"cvss":{"score":5.6,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:P/AC:L/PR:H/UI:R/S:C/C:H/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"aliyun-oss-client is a rust client for Alibaba Cloud OSS. Users of this library will be affected, the incoming secret will be disclosed unintentionally. This issue has been patched in version 0.8.1.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Exposure of sensitive information in aliyun-oss-client","id":"CVE-2022-39397","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"information_disclosure","year":"2022"},"n_packages":3,"n_references":2,"next":{"headline":"InfotelGLPI vulnerable to Cross-site Scripting","id":"CVE-2022-39398"},"packages":[{"ecosystem":"crates.io","fixed":["0.8.1"],"introduced":["0"],"last_affected":[],"package":"aliyun-oss-client","purl":null,"source":"GHSA-3w3h-7xgx-grwc"},{"ecosystem":"crates.io","fixed":["0.8.1"],"introduced":["0"],"last_affected":[],"package":"aliyun-oss-client","purl":"pkg:cargo/aliyun-oss-client","source":"GHSA-3w3h-7xgx-grwc"},{"ecosystem":"crates.io","fixed":["0.8.1"],"introduced":["0.0.0-0"],"last_affected":[],"package":"aliyun-oss-client","purl":"pkg:cargo/aliyun-oss-client","source":"RUSTSEC-2022-0089"}],"prev":{"headline":"Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser","id":"CVE-2022-39396"},"products":["oss-rs"],"published":"2022-11-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["tu6ge"]},"summary":"The aliyun-oss-client library unintentionally discloses sensitive secrets, requiring users to upgrade to the patched version.","url":"https://insights.sbomify.com/CVE-2022-39397/"}