# CVE-2022-39397: Exposure of sensitive information in aliyun-oss-client

> The aliyun-oss-client library unintentionally discloses sensitive secrets, requiring users to upgrade to the patched version.

- **Severity:** Medium 5.6 (`CVSS:3.1/AV:P/AC:L/PR:H/UI:R/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Nov 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-3w3h-7xgx-grwc, RUSTSEC-2022-0089

## What is CVE-2022-39397?

CVE-2022-39397 is a medium-severity vulnerability in tu6ge oss-rs, published on 22 Nov 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

aliyun-oss-client is a rust client for Alibaba Cloud OSS. Users of this library will be affected, the incoming secret will be disclosed unintentionally. This issue has been patched in version 0.8.1.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-39397?

3 open source packages ship an affected version, including aliyun-oss-client. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aliyun-oss-client` | crates.io | All versions | 0.8.1 |
| `aliyun-oss-client` | crates.io | All versions | 0.8.1 |
| `aliyun-oss-client` | crates.io | From 0.0.0-0 | 0.8.1 |

Products: Aliyun-Oss-Client Project Aliyun-Oss-Client.

## How do I fix CVE-2022-39397?

Upgrade aliyun-oss-client to 0.8.1 or later.

## Is CVE-2022-39397 being exploited?

There is no known exploitation of CVE-2022-39397 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39397 and fix it if it is affected.

What it is: CVE-2022-39397 is a medium-severity vulnerability in tu6ge oss-rs, published on 22 Nov 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-39397 in the wild and no public exploit code.

Affected packages and fixed versions:
- aliyun-oss-client (crates.io): affected all versions; fixed in 0.8.1
- aliyun-oss-client (crates.io): affected all versions; fixed in 0.8.1
- aliyun-oss-client (crates.io): affected from 0.0.0-0; fixed in 0.8.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39397/ (Markdown: https://insights.sbomify.com/CVE-2022-39397/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39397
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39397
- OSV: https://osv.dev/vulnerability/CVE-2022-39397

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39397/
Summaries are generated and may contain mistakes; the official description above is the record.
