{"answers":{"affected":"3 open source packages ship an affected version, including github.com/kiali/kiali. It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-3962 in the wild and no public exploit code.","fix":"Upgrade github.com/kiali/kiali to 1.57.4 or later.","what":"CVE-2022-3962 is a medium-severity cross-site scripting vulnerability in Red Hat OpenShift Service Mesh 2.1, published on 23 Sep 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-3962 and fix it if it is affected.\n\nWhat it is: CVE-2022-3962 is a medium-severity cross-site scripting vulnerability in Red Hat OpenShift Service Mesh 2.1, published on 23 Sep 2023. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-3962 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/kiali/kiali (Go): affected all versions; fixed in 1.57.4\n- github.com/kiali/kiali (Go): affected all versions; fixed in 1.57.4\n- github.com/kiali/kiali (Go): affected all versions; fixed in 1.57.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-3962/ (Markdown: https://insights.sbomify.com/CVE-2022-3962/index.md)","id":"CVE-2022-3962","markdown":"https://insights.sbomify.com/CVE-2022-3962/index.md","name":"CVE-2022-3962","record":{"aliases":["ECHO-b512-ef1d-bd95","GHSA-6f4m-j56w-55c3","GO-2023-2075","MINI-4rvv-j693-4xvm","MINI-9xrh-4hj7-cr72"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Kiali UI","requires_auth":"none","summary":"An attacker can inject arbitrary text into Kiali UI error messages due to improper error handling, potentially misleading users or altering displayed content.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"kiali","vendor":"kiali"},{"product":"openshift_service_mesh","vendor":"redhat"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"A content spoofing vulnerability was found in Kiali. It was discovered that Kiali does not implement error handling when the page or endpoint being accessed cannot be found. This issue allows an attacker to perform arbitrary text injection when an error response is retrieved from the URL being accessed.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Kiali: error message spoofing in kiali ui","id":"CVE-2022-3962","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":3,"n_references":3,"next":{"headline":"gnuboard5 FAQ Key ID faq.php cross site scripting","id":"CVE-2022-3963"},"packages":[{"ecosystem":"Go","fixed":["1.57.4"],"introduced":["0"],"last_affected":[],"package":"github.com/kiali/kiali","purl":null,"source":"GHSA-6f4m-j56w-55c3"},{"ecosystem":"Go","fixed":["1.57.4"],"introduced":["0"],"last_affected":[],"package":"github.com/kiali/kiali","purl":"pkg:golang/github.com/kiali/kiali","source":"GHSA-6f4m-j56w-55c3"},{"ecosystem":"Go","fixed":["1.57.4"],"introduced":["0"],"last_affected":[],"package":"github.com/kiali/kiali","purl":"pkg:golang/github.com/kiali/kiali","source":"GO-2023-2075"}],"prev":{"headline":"Directorist \u003c 7.4.4 - Subscriber+ Sensitive Information Disclosure","id":"CVE-2022-3961"},"products":["OpenShift Service Mesh 2.1","Red Hat OpenShift Service Mesh 2.3 for RHEL 8"],"published":"2023-09-23","related":[{"cvss_score":8.6,"headline":"Hard coded cryptographic key in Kiali","id":"CVE-2020-1764","kev_date_added":null,"published":"2020-03-26"},{"cvss_score":7,"headline":"Insufficient Session Expiration in Kiali","id":"CVE-2020-1762","kev_date_added":null,"published":"2020-04-27"},{"cvss_score":6.5,"headline":"Kiali Authentication Bypass vulnerability","id":"CVE-2021-20278","kev_date_added":null,"published":"2021-05-28"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["Red Hat"]},"summary":"An attacker can inject arbitrary text into Kiali UI error messages due to improper error handling, potentially misleading users or altering displayed content.","url":"https://insights.sbomify.com/CVE-2022-3962/"}