CVE-2022-3966 Ultimate Member Plugin Template class-shortcodes.php load_template pathname traversal

Medium 4.3 Published Updated

Remote attackers can exploit a path traversal vulnerability in the Ultimate Member WordPress plugin to read arbitrary files or potentially execute code.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2022-3966?

CVE-2022-3966 is a medium-severity path traversal vulnerability in unspecified Ultimate Member Plugin, published on 13 Nov 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A vulnerability, which was classified as critical, has been found in Ultimate Member Plugin up to 2.5.0. This issue affects the function load_template of the file includes/core/class-shortcodes.php of the component Template Handler. The manipulation of the argument tpl leads to pathname traversal. The attack may be initiated remotely. Upgrading to version 2.5.1 is able to address this issue. The name of the patch is e1bc94c1100f02a129721ba4be5fbc44c3d78ec4. It is recommended to upgrade the affected component. The identifier VDB-213545 was assigned to this vulnerability.

Weakness: CWE-22

Which versions are affected by CVE-2022-3966?

It affects 1 product.

Products include Ultimatemember Ultimate Member.

How do I fix CVE-2022-3966?

No fix has been published for CVE-2022-3966 yet. Limit exposure of the affected software until one is available.

Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.

Is CVE-2022-3966 being exploited?

There is no known exploitation of CVE-2022-3966 in the wild and no public exploit code.

Sources

Also known as GHSA-h2hj-3x68-wc2c.

Is CVE-2022-3966 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free