{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-3966 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2022-3966 yet. Limit exposure of the affected software until one is available.","what":"CVE-2022-3966 is a medium-severity path traversal vulnerability in unspecified Ultimate Member Plugin, published on 13 Nov 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-3966 and fix it if it is affected.\n\nWhat it is: CVE-2022-3966 is a medium-severity path traversal vulnerability in unspecified Ultimate Member Plugin, published on 13 Nov 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-3966 in the wild and no public exploit code.\n\nAffected product: unspecified Ultimate Member Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-3966/ (Markdown: https://insights.sbomify.com/CVE-2022-3966/index.md)","id":"CVE-2022-3966","markdown":"https://insights.sbomify.com/CVE-2022-3966/index.md","name":"CVE-2022-3966","record":{"aliases":["GHSA-h2hj-3x68-wc2c"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"WordPress plugin","requires_auth":"low_privilege","summary":"Remote attackers can exploit a path traversal vulnerability in the Ultimate Member WordPress plugin to read arbitrary files or potentially execute code.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"ultimate_member","vendor":"ultimatemember"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"A vulnerability, which was classified as critical, has been found in Ultimate Member Plugin up to 2.5.0. This issue affects the function load_template of the file includes/core/class-shortcodes.php of the component Template Handler. The manipulation of the argument tpl leads to pathname traversal. The attack may be initiated remotely. Upgrading to version 2.5.1 is able to address this issue. The name of the patch is e1bc94c1100f02a129721ba4be5fbc44c3d78ec4. It is recommended to upgrade the affected component. The identifier VDB-213545 was assigned to this vulnerability.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Ultimate Member Plugin Template class-shortcodes.php load_template pathname traversal","id":"CVE-2022-3966","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"path_traversal","year":"2022"},"n_packages":0,"n_references":3,"next":{"headline":"Vesta Control Panel sed main.sh argument injection","id":"CVE-2022-3967"},"packages":[],"prev":{"headline":"ffmpeg QuickTime Graphics Video Encoder smcenc.c smc_encode_stream out-of-bounds","id":"CVE-2022-3965"},"products":["Ultimate Member Plugin"],"published":"2022-11-13","related":[{"cvss_score":10,"headline":"Privilege escalation in n/a","id":"CVE-2020-36155","kev_date_added":null,"published":"2021-01-04"},{"cvss_score":10,"headline":"Privilege escalation in n/a","id":"CVE-2020-36157","kev_date_added":null,"published":"2021-01-04"},{"cvss_score":9.9,"headline":"Privilege escalation in n/a","id":"CVE-2020-36156","kev_date_added":null,"published":"2021-01-04"},{"cvss_score":9.8,"headline":"SQL injection in Ultimate Member – User Profile, Registration, Login, Member Directory, Content Restriction \u0026 Membership Plugin","id":"CVE-2024-1071","kev_date_added":null,"published":"2024-03-13"},{"cvss_score":9.8,"headline":"Ultimate Member \u003c 2.6.7 - Unauthenticated Privilege Escalation","id":"CVE-2023-3460","kev_date_added":null,"published":"2023-07-04"},{"cvss_score":8.8,"headline":"Auth bypass in n/a","id":"CVE-2019-10270","kev_date_added":null,"published":"2019-06-21"},{"cvss_score":8.8,"headline":"Cross-site request forgery in n/a","id":"CVE-2019-10673","kev_date_added":null,"published":"2019-04-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-15","vendors":["unspecified"]},"summary":"Remote attackers can exploit a path traversal vulnerability in the Ultimate Member WordPress plugin to read arbitrary files or potentially execute code.","url":"https://insights.sbomify.com/CVE-2022-3966/"}