# CVE-2022-3966: Ultimate Member Plugin Template class-shortcodes.php load_template pathname traversal

> Remote attackers can exploit a path traversal vulnerability in the Ultimate Member WordPress plugin to read arbitrary files or potentially execute code.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 13 Nov 2022
- **Updated:** 15 Apr 2025
- **Also known as:** GHSA-h2hj-3x68-wc2c

## What is CVE-2022-3966?

CVE-2022-3966 is a medium-severity path traversal vulnerability in unspecified Ultimate Member Plugin, published on 13 Nov 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability, which was classified as critical, has been found in Ultimate Member Plugin up to 2.5.0. This issue affects the function load_template of the file includes/core/class-shortcodes.php of the component Template Handler. The manipulation of the argument tpl leads to pathname traversal. The attack may be initiated remotely. Upgrading to version 2.5.1 is able to address this issue. The name of the patch is e1bc94c1100f02a129721ba4be5fbc44c3d78ec4. It is recommended to upgrade the affected component. The identifier VDB-213545 was assigned to this vulnerability.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2022-3966?

It affects 1 product.


Products: Ultimatemember Ultimate Member.

## How do I fix CVE-2022-3966?

No fix has been published for CVE-2022-3966 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-3966 being exploited?

There is no known exploitation of CVE-2022-3966 in the wild and no public exploit code.

## Other vulnerabilities in unspecified Ultimate Member Plugin

- [CVE-2020-36155](https://insights.sbomify.com/CVE-2020-36155/): Privilege escalation in n/a (critical 10.0)
- [CVE-2020-36157](https://insights.sbomify.com/CVE-2020-36157/): Privilege escalation in n/a (critical 10.0)
- [CVE-2020-36156](https://insights.sbomify.com/CVE-2020-36156/): Privilege escalation in n/a (critical 9.9)
- [CVE-2024-1071](https://insights.sbomify.com/CVE-2024-1071/): SQL injection in Ultimate Member – User Profile, Registration, Login, Member Directory, Content Restriction & Membership Plugin (critical 9.8)
- [CVE-2023-3460](https://insights.sbomify.com/CVE-2023-3460/): Ultimate Member < 2.6.7 - Unauthenticated Privilege Escalation (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-3966 and fix it if it is affected.

What it is: CVE-2022-3966 is a medium-severity path traversal vulnerability in unspecified Ultimate Member Plugin, published on 13 Nov 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-3966 in the wild and no public exploit code.

Affected product: unspecified Ultimate Member Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-3966/ (Markdown: https://insights.sbomify.com/CVE-2022-3966/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-3966
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-3966
- OSV: https://osv.dev/vulnerability/CVE-2022-3966

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-3966/
Summaries are generated and may contain mistakes; the official description above is the record.
