# CVE-2022-3975: NukeViet CMS Data URL Request.php filterAttr cross site scripting


- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 13 Nov 2022
- **Updated:** 15 Apr 2025
- **Also known as:** GHSA-x45f-j34v-75xm

## What is CVE-2022-3975?

CVE-2022-3975 is a low-severity vulnerability in NukeViet CMS, published on 13 Nov 2022. 

### Official description

A vulnerability, which was classified as problematic, has been found in NukeViet CMS. Affected by this issue is the function filterAttr of the file vendor/vinades/nukeviet/Core/Request.php of the component Data URL Handler. The manipulation of the argument attrSubSet leads to cross site scripting. The attack may be launched remotely. Upgrading to version 4.5 is able to address this issue. The name of the patch is 0b3197fad950bb3383e83039a8ee4c9509b3ce02. It is recommended to upgrade the affected component. VDB-213554 is the identifier assigned to this vulnerability.

Weakness: CWE-707 (Improper Neutralization)

## Which versions are affected by CVE-2022-3975?

2 open source packages ship an affected version, including nukeviet/nukeviet. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nukeviet/nukeviet` | Packagist | All versions | 4.5 |
| `nukeviet/nukeviet` | Packagist | All versions | 4.5 |

Products: Nukeviet Nukeviet.

## How do I fix CVE-2022-3975?

Upgrade nukeviet/nukeviet to 4.5 or later.

## Is CVE-2022-3975 being exploited?

There is no known exploitation of CVE-2022-3975 in the wild and no public exploit code.

## Other vulnerabilities in NukeViet CMS

- [CVE-2020-21808](https://insights.sbomify.com/CVE-2020-21808/): NukeViet SQL Injection vulnerability via topicsid parameter (critical 9.8)
- [CVE-2020-21809](https://insights.sbomify.com/CVE-2020-21809/): NukeViet SQL Injection vulnerability (critical 9.8)
- [CVE-2019-7725](https://insights.sbomify.com/CVE-2019-7725/): Deserialization of Untrusted Data in NukeViet (critical 9.8)
- [CVE-2019-7726](https://insights.sbomify.com/CVE-2019-7726/): SQL Injection in NukeViet (critical 9.8)
- [CVE-2020-13155](https://insights.sbomify.com/CVE-2020-13155/): NukeViet Cross-Site Request Forgery (CSRF) (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-3975 and fix it if it is affected.

What it is: CVE-2022-3975 is a low-severity vulnerability in NukeViet CMS, published on 13 Nov 2022. 
Exploitation: There is no known exploitation of CVE-2022-3975 in the wild and no public exploit code.

Affected packages and fixed versions:
- nukeviet/nukeviet (Packagist): affected all versions; fixed in 4.5
- nukeviet/nukeviet (Packagist): affected all versions; fixed in 4.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-3975/ (Markdown: https://insights.sbomify.com/CVE-2022-3975/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-3975
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-3975
- OSV: https://osv.dev/vulnerability/CVE-2022-3975

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-3975/
Summaries are generated and may contain mistakes; the official description above is the record.
