{"answers":{"affected":"2 open source packages ship an affected version, including nodebb. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3978 exists.","fix":"Upgrade nodebb to 2.5.8 or later.","what":"CVE-2022-3978 is a medium-severity vulnerability in unspecified NodeBB, published on 13 Nov 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-3978 and fix it if it is affected.\n\nWhat it is: CVE-2022-3978 is a medium-severity vulnerability in unspecified NodeBB, published on 13 Nov 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3978 exists.\n\nAffected packages and fixed versions:\n- nodebb (npm): affected all versions; fixed in 2.5.8\n- nodebb (npm): affected all versions; fixed in 2.5.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-3978/ (Markdown: https://insights.sbomify.com/CVE-2022-3978/index.md)","id":"CVE-2022-3978","markdown":"https://insights.sbomify.com/CVE-2022-3978/index.md","name":"CVE-2022-3978","record":{"aliases":["GHSA-5gwx-wf9g-r5mx"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"NodeBB forum software","requires_auth":"none","summary":"Attackers can perform cross-site request forgery on the abort registration endpoint, requiring users to upgrade NodeBB.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"nodebb","vendor":"nodebb"}],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"},{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"A vulnerability, which was classified as problematic, was found in NodeBB up to 2.5.7. This affects an unknown part of the file /register/abort. The manipulation leads to cross-site request forgery. It is possible to initiate the attack remotely. Upgrading to version 2.5.8 is able to address this issue. The name of the patch is 2f9d8c350e54543f608d3d4c8e1a49bbb6cdea38. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-213555.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"NodeBB abort cross-site request forgery","id":"CVE-2022-3978","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"csrf","year":"2022"},"n_packages":2,"n_references":4,"next":{"headline":"NagVis CoreLogonMultisite.php checkAuthCookie type conversion","id":"CVE-2022-3979"},"packages":[{"ecosystem":"npm","fixed":["2.5.8"],"introduced":["0"],"last_affected":[],"package":"nodebb","purl":null,"source":"GHSA-5gwx-wf9g-r5mx"},{"ecosystem":"npm","fixed":["2.5.8"],"introduced":["0"],"last_affected":[],"package":"nodebb","purl":"pkg:npm/nodebb","source":"GHSA-5gwx-wf9g-r5mx"}],"prev":{"headline":"Use after free in Kernel","id":"CVE-2022-3977"},"products":["NodeBB"],"published":"2022-11-13","related":[{"cvss_score":10,"headline":"NodeBB vulnerable to path traversal and code execution via prototype vulnerability","id":"CVE-2023-26045","kev_date_added":null,"published":"2023-07-24"},{"cvss_score":9.9,"headline":"Account takeover in NodeBB","id":"CVE-2020-15149","kev_date_added":null,"published":"2020-08-19"},{"cvss_score":9.8,"headline":"Code injection in n/a","id":"CVE-2023-43187","kev_date_added":null,"published":"2023-09-26"},{"cvss_score":9.8,"headline":"API token verification can be bypassed","id":"CVE-2021-43786","kev_date_added":null,"published":"2021-11-29"},{"cvss_score":9.4,"headline":"Account takeover via prototype vulnerability","id":"CVE-2022-46164","kev_date_added":null,"published":"2022-12-05"},{"cvss_score":9,"headline":"Account takeover via cryptographically weak PRNG in NodeBB Forum","id":"CVE-2022-36045","kev_date_added":null,"published":"2022-08-31"},{"cvss_score":9,"headline":"XSS via prototype pollution","id":"CVE-2021-43787","kev_date_added":null,"published":"2021-11-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-15","vendors":["unspecified"]},"summary":"Attackers can perform cross-site request forgery on the abort registration endpoint, requiring users to upgrade NodeBB.","url":"https://insights.sbomify.com/CVE-2022-3978/"}