# CVE-2022-3978: NodeBB abort cross-site request forgery

> Attackers can perform cross-site request forgery on the abort registration endpoint, requiring users to upgrade NodeBB.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Nov 2022
- **Updated:** 15 Apr 2025
- **Also known as:** GHSA-5gwx-wf9g-r5mx

## What is CVE-2022-3978?

CVE-2022-3978 is a medium-severity vulnerability in unspecified NodeBB, published on 13 Nov 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A vulnerability, which was classified as problematic, was found in NodeBB up to 2.5.7. This affects an unknown part of the file /register/abort. The manipulation leads to cross-site request forgery. It is possible to initiate the attack remotely. Upgrading to version 2.5.8 is able to address this issue. The name of the patch is 2f9d8c350e54543f608d3d4c8e1a49bbb6cdea38. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-213555.

Weakness: CWE-352 (Cross-Site Request Forgery), CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2022-3978?

2 open source packages ship an affected version, including nodebb. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nodebb` | npm | All versions | 2.5.8 |
| `nodebb` | npm | All versions | 2.5.8 |

Products: Nodebb Nodebb.

## How do I fix CVE-2022-3978?

Upgrade nodebb to 2.5.8 or later.

## Is CVE-2022-3978 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3978 exists.

## Other vulnerabilities in unspecified NodeBB

- [CVE-2023-26045](https://insights.sbomify.com/CVE-2023-26045/): NodeBB vulnerable to path traversal and code execution via prototype vulnerability (critical 10.0)
- [CVE-2020-15149](https://insights.sbomify.com/CVE-2020-15149/): Account takeover in NodeBB (critical 9.9)
- [CVE-2023-43187](https://insights.sbomify.com/CVE-2023-43187/): Code injection in n/a (critical 9.8)
- [CVE-2021-43786](https://insights.sbomify.com/CVE-2021-43786/): API token verification can be bypassed (critical 9.8)
- [CVE-2022-46164](https://insights.sbomify.com/CVE-2022-46164/): Account takeover via prototype vulnerability (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-3978 and fix it if it is affected.

What it is: CVE-2022-3978 is a medium-severity vulnerability in unspecified NodeBB, published on 13 Nov 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-3978 exists.

Affected packages and fixed versions:
- nodebb (npm): affected all versions; fixed in 2.5.8
- nodebb (npm): affected all versions; fixed in 2.5.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-3978/ (Markdown: https://insights.sbomify.com/CVE-2022-3978/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-3978
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-3978
- OSV: https://osv.dev/vulnerability/CVE-2022-3978

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-3978/
Summaries are generated and may contain mistakes; the official description above is the record.
