CVE-2022-39835 Business logic in n/a
Attackers in a chat can modify messages they did not send via crafted XML stanzas in Gajim.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-39835?
CVE-2022-39835 is a medium-severity vulnerability in n/a, published on 27 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
An issue was discovered in Gajim through 1.4.7. The vulnerability allows attackers, via crafted XML stanzas, to correct messages that were not sent by them. The attacker needs to be part of the group chat or single chat. The fixed version is 1.5.0.
Weakness: CWE-284
Which versions are affected by CVE-2022-39835?
It affects 1 product.
Linux distribution packages (1)
gajim openSUSE:Tumbleweed | All versions | 1.5.1-1.1 |
Products include Gajim Gajim.
How do I fix CVE-2022-39835?
Upgrade to a fixed version.
Is CVE-2022-39835 being exploited?
There is no known exploitation of CVE-2022-39835 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as DEBIAN-CVE-2022-39835, GHSA-q3pp-76rw-fqvm, UBUNTU-CVE-2022-39835, openSUSE-SU-2024:12354-1.