# CVE-2022-39944: The Apache Linkis JDBC EngineConn module has a RCE Vulnerability


- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 26 Oct 2022
- **Updated:** 7 May 2025
- **Also known as:** GHSA-3f3w-gmqf-4hj3

## What is CVE-2022-39944?

CVE-2022-39944 is a high-severity vulnerability in Apache Linkis, published on 26 Oct 2022. 

### Official description

In Apache Linkis <=1.2.0 when used with the MySQL Connector/J, a deserialization vulnerability with possible remote code execution impact exists when an attacker has write access to a database and configures a JDBC EC with a MySQL data source and malicious parameters. Therefore, the parameters in the jdbc url should be blacklisted. Versions of Apache Linkis <= 1.2.0 will be affected, We recommend users to update to 1.3.0.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2022-39944?

2 open source packages ship an affected version, including org.apache.linkis:linkis. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.linkis:linkis` | Maven | All versions | 1.3.0 |
| `org.apache.linkis:linkis` | Maven | All versions | 1.3.0 |

Products: Apache Linkis.

## How do I fix CVE-2022-39944?

Upgrade org.apache.linkis:linkis to 1.3.0 or later.

## Is CVE-2022-39944 being exploited?

There is no known exploitation of CVE-2022-39944 in the wild and no public exploit code.

## Other vulnerabilities in Apache Linkis

- [CVE-2023-27602](https://insights.sbomify.com/CVE-2023-27602/): Apache Linkis publicsercice module unrestricted upload of file (critical 9.8)
- [CVE-2023-27603](https://insights.sbomify.com/CVE-2023-27603/): Apache Linkis Mangaer module engineConn material upload exists Zip Slip issue (critical 9.8)
- [CVE-2023-29215](https://insights.sbomify.com/CVE-2023-29215/): Apache Linkis JDBC EngineCon has a deserialization command execution (critical 9.8)
- [CVE-2023-29216](https://insights.sbomify.com/CVE-2023-29216/): Apache Linkis DatasourceManager module has a deserialization command execution (critical 9.8)
- [CVE-2023-27987](https://insights.sbomify.com/CVE-2023-27987/): Apache Linkis gateway module token authentication bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39944 and fix it if it is affected.

What it is: CVE-2022-39944 is a high-severity vulnerability in Apache Linkis, published on 26 Oct 2022. 
Exploitation: There is no known exploitation of CVE-2022-39944 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.linkis:linkis (Maven): affected all versions; fixed in 1.3.0
- org.apache.linkis:linkis (Maven): affected all versions; fixed in 1.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39944/ (Markdown: https://insights.sbomify.com/CVE-2022-39944/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39944
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39944
- OSV: https://osv.dev/vulnerability/CVE-2022-39944

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39944/
Summaries are generated and may contain mistakes; the official description above is the record.
