# CVE-2022-3996: X.509 Policy Constraints Double Locking

> A double locking bug in OpenSSL causes a denial of service when processing malformed X.509 policy constraints if policy processing is enabled.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Dec 2022
- **Updated:** 3 Aug 2024
- **Also known as:** ALPINE-CVE-2022-3996, AZL-40306, CLEANSTART-2026-FU56835, DEBIAN-CVE-2022-3996, GHSA-vr8j-hgmm-jh9r, UBUNTU-CVE-2022-3996, openSUSE-SU-2024:12573-1

## What is CVE-2022-3996?

CVE-2022-3996 is a high-severity denial of service vulnerability in Openssl Openssl, published on 13 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

If an X.509 certificate contains a malformed policy constraint and
policy processing is enabled, then a write lock will be taken twice
recursively.  On some operating systems (most widely: Windows) this
results in a denial of service when the affected process hangs.  Policy
processing being enabled on a publicly facing server is not considered
to be a common setup.

Policy processing is enabled by passing the `-policy'
argument to the command line utilities or by calling the
`X509_VERIFY_PARAM_set1_policies()' function.

Update (31 March 2023): The description of the policy processing enablement
was corrected based on CVE-2023-0466.

Weakness: CWE-667 (Improper Locking)

## Which versions are affected by CVE-2022-3996?

2 open source packages ship an affected version, including openssl-src. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openssl-src` | crates.io | From 300.0.0 | 300.0.12 |
| `openssl-src` | crates.io | From 300.0.0 | 300.0.12 |
| `openssl-3` | openSUSE:Tumbleweed | All versions | 3.0.7-2.1 |

Products: Openssl Openssl.

## How do I fix CVE-2022-3996?

Upgrade openssl-src to 300.0.12 or later.

## Is CVE-2022-3996 being exploited?

There is no known exploitation of CVE-2022-3996 in the wild and no public exploit code.

## Other vulnerabilities in Openssl Openssl

- [CVE-2009-3245](https://insights.sbomify.com/CVE-2009-3245/): Null dereference in n/a (critical 10.0)
- [CVE-2006-3738](https://insights.sbomify.com/CVE-2006-3738/): Memory corruption in n/a (critical 10.0)
- [CVE-2026-63073](https://insights.sbomify.com/CVE-2026-63073/): Untrusted Sender DN Used as Format String in CMP Response Validation (critical 9.8)
- [CVE-2016-6309](https://insights.sbomify.com/CVE-2016-6309/): Use after free in n/a (critical 9.8)
- [CVE-2016-0799](https://insights.sbomify.com/CVE-2016-0799/): Integer overflow in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-3996 and fix it if it is affected.

What it is: CVE-2022-3996 is a high-severity denial of service vulnerability in Openssl Openssl, published on 13 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-3996 in the wild and no public exploit code.

Affected packages and fixed versions:
- openssl-src (crates.io): affected from 300.0.0; fixed in 300.0.12
- openssl-src (crates.io): affected from 300.0.0; fixed in 300.0.12

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-3996/ (Markdown: https://insights.sbomify.com/CVE-2022-3996/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-3996
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-3996
- OSV: https://osv.dev/vulnerability/CVE-2022-3996

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-3996/
Summaries are generated and may contain mistakes; the official description above is the record.
