# CVE-2022-39986: RaspAP Command Injection vulnerability

> Unauthenticated attackers can execute arbitrary commands via the cfg_id parameter in RaspAP's OpenVPN configuration scripts.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2023
- **Updated:** 21 Oct 2024
- **Also known as:** GHSA-7c28-wg7r-pg6f

## What is CVE-2022-39986?

CVE-2022-39986 is a critical command injection vulnerability in n/a, published on 1 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A Command injection vulnerability in RaspAP 2.8.0 thru 2.8.7 allows unauthenticated attackers to execute arbitrary commands via the cfg_id parameter in /ajax/openvpn/activate_ovpncfg.php and /ajax/openvpn/del_ovpncfg.php.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2022-39986?

2 open source packages ship an affected version, including billz/raspap-webgui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `billz/raspap-webgui` | Packagist | From 2.8.0 | 2.8.8 |
| `billz/raspap-webgui` | Packagist | From 2.8.0 | 2.8.8 |

Products: Raspap Raspap.

## How do I fix CVE-2022-39986?

Upgrade billz/raspap-webgui to 2.8.8 or later.

## Is CVE-2022-39986 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39986 exists.

Public exploit code:

- RaspAP Unauthenticated Command Injection (metasploit)
- bash script for automated discovery and exploitation of machines with the CVE-2022-39986 vulnerability (github_poc): https://github.com/mind2hex/CVE-2022-39986-RaspAP-2.8.0-2.8.7-RCE
- RaspAP 2.8.7 - Unauthenticated Command Injection (nuclei): http/cves/2022/CVE-2022-39986.yaml

## Other vulnerabilities in n/a

- [CVE-2021-33357](https://insights.sbomify.com/CVE-2021-33357/): Command injection in n/a (critical 9.8)
- [CVE-2022-39987](https://insights.sbomify.com/CVE-2022-39987/): RaspAP Command Injection vulnerability (high 8.8)
- [CVE-2023-30260](https://insights.sbomify.com/CVE-2023-30260/): RaspAP raspap-webgui Command Injection vulnerability (high 8.8)
- [CVE-2021-38556](https://insights.sbomify.com/CVE-2021-38556/): Command Injection in RaspAP 2.6.6 (high 8.8)
- [CVE-2021-38557](https://insights.sbomify.com/CVE-2021-38557/): raspap-webgui in RaspAP 2.6.6 allows attackers to execute commands as root because of the insecure sudoers permissions. (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-39986 and fix it if it is affected.

What it is: CVE-2022-39986 is a critical command injection vulnerability in n/a, published on 1 Aug 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39986 exists.

Affected packages and fixed versions:
- billz/raspap-webgui (Packagist): affected from 2.8.0; fixed in 2.8.8
- billz/raspap-webgui (Packagist): affected from 2.8.0; fixed in 2.8.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-39986/ (Markdown: https://insights.sbomify.com/CVE-2022-39986/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-39986
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-39986
- OSV: https://osv.dev/vulnerability/CVE-2022-39986

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-39986/
Summaries are generated and may contain mistakes; the official description above is the record.
