{"answers":{"affected":"2 open source packages ship an affected version, including billz/raspap-webgui. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39987 exists.","fix":"Upgrade billz/raspap-webgui to 2.9.5 or later.","what":"CVE-2022-39987 is a high-severity command injection vulnerability in n/a, published on 1 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-39987 and fix it if it is affected.\n\nWhat it is: CVE-2022-39987 is a high-severity command injection vulnerability in n/a, published on 1 Aug 2023. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-39987 exists.\n\nAffected packages and fixed versions:\n- billz/raspap-webgui (Packagist): affected from 2.8.0; fixed in 2.9.5\n- billz/raspap-webgui (Packagist): affected from 2.8.0; fixed in 2.9.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-39987/ (Markdown: https://insights.sbomify.com/CVE-2022-39987/index.md)","id":"CVE-2022-39987","markdown":"https://insights.sbomify.com/CVE-2022-39987/index.md","name":"CVE-2022-39987","record":{"aliases":["GHSA-7r88-wjhj-jr8m"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"RaspAP web interface","requires_auth":"low_privilege","summary":"Authenticated attackers can execute arbitrary OS commands as root via the get_wgkey.php endpoint in RaspAP.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"raspap","vendor":"raspap"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"A Command injection vulnerability in RaspAP 2.8.0 thru 2.9.2 allows an authenticated attacker to execute arbitrary OS commands as root via the \"entity\" POST parameters in /ajax/networking/get_wgkey.php.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"RaspAP Command Injection vulnerability","id":"CVE-2022-39987","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"command_injection","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2022-39988"},"packages":[{"ecosystem":"Packagist","fixed":["2.9.5"],"introduced":["2.8.0"],"last_affected":[],"package":"billz/raspap-webgui","purl":null,"source":"GHSA-7r88-wjhj-jr8m"},{"ecosystem":"Packagist","fixed":["2.9.5"],"introduced":["2.8.0"],"last_affected":[],"package":"billz/raspap-webgui","purl":"pkg:composer/billz/raspap-webgui","source":"GHSA-7r88-wjhj-jr8m"}],"prev":{"headline":"RaspAP Command Injection vulnerability","id":"CVE-2022-39986"},"products":["n/a"],"published":"2023-08-01","related":[{"cvss_score":9.8,"headline":"RaspAP Command Injection vulnerability","id":"CVE-2022-39986","kev_date_added":null,"published":"2023-08-01"},{"cvss_score":9.8,"headline":"Command injection in n/a","id":"CVE-2021-33357","kev_date_added":null,"published":"2021-06-09"},{"cvss_score":8.8,"headline":"RaspAP raspap-webgui Command Injection vulnerability","id":"CVE-2023-30260","kev_date_added":null,"published":"2023-06-23"},{"cvss_score":8.8,"headline":"Command Injection in RaspAP 2.6.6","id":"CVE-2021-38556","kev_date_added":null,"published":"2021-08-24"},{"cvss_score":8.8,"headline":"raspap-webgui in RaspAP 2.6.6 allows attackers to execute commands as root because of the insecure sudoers permissions.","id":"CVE-2021-38557","kev_date_added":null,"published":"2021-08-24"},{"cvss_score":8.8,"headline":"Command injection in n/a","id":"CVE-2021-33356","kev_date_added":null,"published":"2021-06-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2024-10-21","vendors":["n/a"]},"summary":"Authenticated attackers can execute arbitrary OS commands as root via the get_wgkey.php endpoint in RaspAP.","url":"https://insights.sbomify.com/CVE-2022-39987/"}