CVE-2022-40023 mako is vulnerable to Regular Expression Denial of Service
An attacker can cause a denial of service in Mako templates by triggering a regular expression denial of service via the Lexer class.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-40023?
CVE-2022-40023 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 7 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Sqlalchemy mako before 1.2.2 is vulnerable to Regular expression Denial of Service when using the Lexer class to parse. This also affects babelplugin and linguaplugin.
Weakness: CWE-1333
Which versions are affected by CVE-2022-40023?
3 open source packages ship an affected version, including mako. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
mako PyPI | All versions | 1.2.2 |
mako PyPI | All versions | 1.2.2 |
mako PyPI | All versions | 1.2.2 |
Linux distribution packages (21)
python3-mako AlmaLinux:8 | All versions | 1.0.6-14.el8 |
python3-mako AlmaLinux:9 | All versions | 1.1.4-6.el9 |
python-mako Red Hat:enterprise_linux:8::appstream | All versions | 0:1.0.6-14.el8 |
python3-mako Red Hat:enterprise_linux:8::appstream | All versions | 0:1.0.6-14.el8 |
python-mako Red Hat:enterprise_linux:9::appstream | All versions | 0:1.1.4-6.el9 |
python3-mako Red Hat:enterprise_linux:9::appstream | All versions | 0:1.1.4-6.el9 |
python-mako Rocky Linux:8 | All versions | 0:1.0.6-14.el8 |
python-mako Rocky Linux:9 | All versions | 0:1.1.4-6.el9 |
python-Mako SUSE:HPE Helion OpenStack 8 | All versions | 1.0.7-3.3.1 |
python-Mako SUSE:Linux Enterprise Module for Basesystem 15 SP3 | All versions | 1.0.7-150000.3.3.1 |
python-Mako SUSE:Linux Enterprise Module for Basesystem 15 SP4 | All versions | 1.0.7-150000.3.3.1 |
python-Mako SUSE:Linux Enterprise Module for Package Hub 15 SP3 | All versions | 1.0.7-150000.3.3.1 |
python-Mako SUSE:Linux Enterprise Module for Package Hub 15 SP4 | All versions | 1.0.7-150000.3.3.1 |
python-Mako SUSE:OpenStack Cloud 8 | All versions | 1.0.7-3.3.1 |
python-Mako SUSE:OpenStack Cloud 9 | All versions | 1.0.7-4.3.1 |
python-Mako SUSE:OpenStack Cloud Crowbar 8 | All versions | 1.0.7-3.3.1 |
python-Mako SUSE:OpenStack Cloud Crowbar 9 | All versions | 1.0.7-4.3.1 |
python-Mako openSUSE:Leap 15.3 | All versions | 1.0.7-150000.3.3.1 |
python-Mako openSUSE:Leap 15.4 | All versions | 1.0.7-150000.3.3.1 |
python-Mako openSUSE:Tumbleweed | All versions | 1.3.0-2.1 |
python-Mako openSUSE:Tumbleweed | All versions | 1.4.1-1.1 |
Products include Debian Debian Linux, Sqlalchemy Mako.
How do I fix CVE-2022-40023?
Upgrade mako to 1.2.2 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2022-40023 being exploited?
There is no known exploitation of CVE-2022-40023 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as ALPINE-CVE-2022-40023, ALSA-2023:2258, ALSA-2023:2893, AZL-10892, DEBIAN-CVE-2022-40023, DLA-3116-1 and 16 more.