# CVE-2022-40023: mako is vulnerable to Regular Expression Denial of Service

> An attacker can cause a denial of service in Mako templates by triggering a regular expression denial of service via the Lexer class.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Sep 2022
- **Updated:** 3 Dec 2025
- **Also known as:** ALPINE-CVE-2022-40023, ALSA-2023:2258, ALSA-2023:2893, AZL-10892, DEBIAN-CVE-2022-40023, DLA-3116-1, DLA-4393-1, GHSA-v973-fxgf-6xhp, MGASA-2022-0350, OESA-2023-1683, PYSEC-2022-260, RHSA-2023:2258, RHSA-2023:2893, RLSA-2023:2258, RLSA-2023:2893, SUSE-SU-2022:3700-1, SUSE-SU-2022:3701-1, SUSE-SU-2022:3979-1, UBUNTU-CVE-2022-40023, USN-5625-1, openSUSE-SU-2024:13610-1, openSUSE-SU-2026:11567-1

## What is CVE-2022-40023?

CVE-2022-40023 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 7 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Sqlalchemy mako before 1.2.2 is vulnerable to Regular expression Denial of Service when using the Lexer class to parse. This also affects babelplugin and linguaplugin.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2022-40023?

3 open source packages ship an affected version, including mako. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mako` | PyPI | All versions | 1.2.2 |
| `mako` | PyPI | All versions | 1.2.2 |
| `mako` | PyPI | All versions | 1.2.2 |
| `python3-mako` | AlmaLinux:8 | All versions | 1.0.6-14.el8 |
| `python3-mako` | AlmaLinux:9 | All versions | 1.1.4-6.el9 |
| `python-mako` | Red Hat:enterprise_linux:8::appstream | All versions | 0:1.0.6-14.el8 |
| `python3-mako` | Red Hat:enterprise_linux:8::appstream | All versions | 0:1.0.6-14.el8 |
| `python-mako` | Red Hat:enterprise_linux:9::appstream | All versions | 0:1.1.4-6.el9 |
| `python3-mako` | Red Hat:enterprise_linux:9::appstream | All versions | 0:1.1.4-6.el9 |
| `python-mako` | Rocky Linux:8 | All versions | 0:1.0.6-14.el8 |
| `python-mako` | Rocky Linux:9 | All versions | 0:1.1.4-6.el9 |
| `python-Mako` | SUSE:HPE Helion OpenStack 8 | All versions | 1.0.7-3.3.1 |
| `python-Mako` | SUSE:Linux Enterprise Module for Basesystem 15 SP3 | All versions | 1.0.7-150000.3.3.1 |
| `python-Mako` | SUSE:Linux Enterprise Module for Basesystem 15 SP4 | All versions | 1.0.7-150000.3.3.1 |
| `python-Mako` | SUSE:Linux Enterprise Module for Package Hub 15 SP3 | All versions | 1.0.7-150000.3.3.1 |
| `python-Mako` | SUSE:Linux Enterprise Module for Package Hub 15 SP4 | All versions | 1.0.7-150000.3.3.1 |
| `python-Mako` | SUSE:OpenStack Cloud 8 | All versions | 1.0.7-3.3.1 |
| `python-Mako` | SUSE:OpenStack Cloud 9 | All versions | 1.0.7-4.3.1 |
| `python-Mako` | SUSE:OpenStack Cloud Crowbar 8 | All versions | 1.0.7-3.3.1 |
| `python-Mako` | SUSE:OpenStack Cloud Crowbar 9 | All versions | 1.0.7-4.3.1 |
| `python-Mako` | openSUSE:Leap 15.3 | All versions | 1.0.7-150000.3.3.1 |
| `python-Mako` | openSUSE:Leap 15.4 | All versions | 1.0.7-150000.3.3.1 |
| `python-Mako` | openSUSE:Tumbleweed | All versions | 1.3.0-2.1 |
| `python-Mako` | openSUSE:Tumbleweed | All versions | 1.4.1-1.1 |

Products: Debian Debian Linux, Sqlalchemy Mako.

## How do I fix CVE-2022-40023?

Upgrade mako to 1.2.2 or later.

## Is CVE-2022-40023 being exploited?

There is no known exploitation of CVE-2022-40023 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-40023 and fix it if it is affected.

What it is: CVE-2022-40023 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 7 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-40023 in the wild and no public exploit code.

Affected packages and fixed versions:
- mako (PyPI): affected all versions; fixed in 1.2.2
- mako (PyPI): affected all versions; fixed in 1.2.2
- mako (PyPI): affected all versions; fixed in 1.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-40023/ (Markdown: https://insights.sbomify.com/CVE-2022-40023/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-40023
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-40023
- OSV: https://osv.dev/vulnerability/CVE-2022-40023

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-40023/
Summaries are generated and may contain mistakes; the official description above is the record.
