CVE-2022-4007 Cross-site scripting in GitLab

Medium 5.4 Published Updated

Attackers can execute arbitrary client-side actions via XSS in GitLab work item titles, potentially compromising user accounts.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-4007?

CVE-2022-4007 is a medium-severity cross-site scripting vulnerability in Gitlab Gitlab, published on 8 Mar 2023. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

A issue has been discovered in GitLab CE/EE affecting all versions from 15.3 prior to 15.7.8, version 15.8 prior to 15.8.4, and version 15.9 prior to 15.9.2 A cross-site scripting vulnerability was found in the title field of work items that allowed attackers to perform arbitrary actions on behalf of victims at client side.

Weakness: CWE-79

Which versions are affected by CVE-2022-4007?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiFrom 15.3.015.7.8, 15.8.4, 15.9.2

Products include Gitlab Gitlab.

How do I fix CVE-2022-4007?

Upgrade gitlab to a fixed version for your release line: 15.7.8, 15.8.4 or 15.9.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2022-4007 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-4007 exists.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-4007, GHSA-q7hv-qq3g-4grg, UBUNTU-CVE-2022-4007.

Is CVE-2022-4007 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free