# CVE-2022-40082: Hertz contains path traversal via normalizePath function

> Attackers can exploit a path traversal flaw in the Hertz Go web framework to read arbitrary files from the server.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Sep 2022
- **Updated:** 21 May 2025
- **Also known as:** GHSA-c9qr-f6c8-rgxf, GO-2022-1027

## What is CVE-2022-40082?

CVE-2022-40082 is a high-severity path traversal vulnerability in n/a, published on 28 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Hertz v0.3.0 ws discovered to contain a path traversal vulnerability via the normalizePath function.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2022-40082?

3 open source packages ship an affected version, including github.com/cloudwego/hertz. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/cloudwego/hertz` | Go | All versions | 0.3.1 |
| `github.com/cloudwego/hertz` | Go | All versions | 0.3.1 |
| `github.com/cloudwego/hertz` | Go | All versions | 0.3.1 |

Products: Cloudwego Hertz.

## How do I fix CVE-2022-40082?

Upgrade github.com/cloudwego/hertz to 0.3.1 or later.

## Is CVE-2022-40082 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-40082 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-40082 and fix it if it is affected.

What it is: CVE-2022-40082 is a high-severity path traversal vulnerability in n/a, published on 28 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-40082 exists.

Affected packages and fixed versions:
- github.com/cloudwego/hertz (Go): affected all versions; fixed in 0.3.1
- github.com/cloudwego/hertz (Go): affected all versions; fixed in 0.3.1
- github.com/cloudwego/hertz (Go): affected all versions; fixed in 0.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-40082/ (Markdown: https://insights.sbomify.com/CVE-2022-40082/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-40082
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-40082
- OSV: https://osv.dev/vulnerability/CVE-2022-40082

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-40082/
Summaries are generated and may contain mistakes; the official description above is the record.
