# CVE-2022-40127: Apache Airflow <2.4.0 has an RCE in a bash example

> An attacker with UI access can execute arbitrary commands via the run_id parameter in example DAGs, requiring an upgrade to secure the system.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Nov 2022
- **Updated:** 30 Apr 2025
- **Also known as:** BIT-airflow-2022-40127, GHSA-6pw3-8h9w-32gc, PYSEC-2022-42982

## What is CVE-2022-40127?

CVE-2022-40127 is a high-severity command injection vulnerability in Apache Airflow, published on 14 Nov 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability in Example Dags of Apache Airflow allows an attacker with UI access who can trigger DAGs, to execute arbitrary commands via manually provided run_id parameter. This issue affects Apache Airflow Apache Airflow versions prior to 2.4.0.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2022-40127?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `apache-airflow` | PyPI | All versions | 2.4.0 |
| `apache-airflow` | PyPI | All versions | 2.4.0 |
| `apache-airflow` | PyPI | All versions | 2.4.0 |
| `airflow` | Bitnami | All versions | 2.4.0 |

Products: Apache Airflow.

## How do I fix CVE-2022-40127?

Upgrade apache-airflow to 2.4.0 or later.

## Is CVE-2022-40127 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-40127 exists.

Public exploit code:

- Apache Airflow < 2.4.0 DAG  example_bash_operator RCE POC (github_poc): https://github.com/Mr-xn/CVE-2022-40127
- CVE-2022-40127 PoC and exploit (github_poc): https://github.com/jakabakos/CVE-2022-40127-Airflow-RCE
- AirFlow < 2.4.0 - Remote Code Execution (nuclei): http/cves/2022/CVE-2022-40127.yaml

## Other vulnerabilities in Apache Airflow

- [CVE-2020-13927](https://insights.sbomify.com/CVE-2020-13927/): Apache Airflow's Experimental API Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-11978](https://insights.sbomify.com/CVE-2020-11978/): Apache Airflow Command Injection (high 8.8, exploited in the wild)
- [CVE-2026-33264](https://insights.sbomify.com/CVE-2026-33264/): Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize() (critical 9.8)
- [CVE-2023-25754](https://insights.sbomify.com/CVE-2023-25754/): Apache Airflow: Privilege escalation using airflow logs (critical 9.8)
- [CVE-2023-22884](https://insights.sbomify.com/CVE-2023-22884/): Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-40127 and fix it if it is affected.

What it is: CVE-2022-40127 is a high-severity command injection vulnerability in Apache Airflow, published on 14 Nov 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-40127 exists.

Affected packages and fixed versions:
- apache-airflow (PyPI): affected all versions; fixed in 2.4.0
- apache-airflow (PyPI): affected all versions; fixed in 2.4.0
- apache-airflow (PyPI): affected all versions; fixed in 2.4.0
- airflow (Bitnami): affected all versions; fixed in 2.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-40127/ (Markdown: https://insights.sbomify.com/CVE-2022-40127/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-40127
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-40127
- OSV: https://osv.dev/vulnerability/CVE-2022-40127

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-40127/
Summaries are generated and may contain mistakes; the official description above is the record.
