# CVE-2022-40186: HashiCorp Vault vulnerable to incorrect metadata access

> Attackers can gain unintended access to key/value paths in HashiCorp Vault when entities have multiple mount accessors with shared alias names.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Sep 2022
- **Updated:** 27 May 2025
- **Also known as:** BIT-vault-2022-40186, GHSA-7cgv-v83v-rr87, GO-2022-1021

## What is CVE-2022-40186?

CVE-2022-40186 is a critical missing authorization vulnerability in Hashicorp Vault, published on 22 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An issue was discovered in HashiCorp Vault and Vault Enterprise before 1.11.3. A vulnerability in the Identity Engine was found where, in a deployment where an entity has multiple mount accessors with shared alias names, Vault may overwrite metadata to the wrong alias due to an issue with checking the proper alias assigned to an entity. This may allow for unintended access to key/value paths using that metadata in Vault.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2022-40186?

8 open source packages ship an affected version, including github.com/hashicorp/vault and vault. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/vault` | Go | From 1.10.0 | 1.10.6 |
| `github.com/hashicorp/vault` | Go | From 1.10.0 | 1.10.6 |
| `github.com/hashicorp/vault` | Go | From 1.11.0 | 1.11.3 |
| `github.com/hashicorp/vault` | Go | From 1.11.0 | 1.11.3 |
| `github.com/hashicorp/vault` | Go | From 1.8.0 | 1.9.9, 1.10.6, 1.11.3 |
| `github.com/hashicorp/vault` | Go | From 1.8.0 | 1.9.9 |
| `github.com/hashicorp/vault` | Go | From 1.8.0 | 1.9.9 |
| `vault` | Bitnami | From 1.8.0 | 1.9.9, 1.10.6, 1.11.3 |

Products: Hashicorp Vault.

## How do I fix CVE-2022-40186?

Upgrade github.com/hashicorp/vault to a fixed version for your release line: 1.10.6, 1.11.3 or 1.9.9.

## Is CVE-2022-40186 being exploited?

There is no known exploitation of CVE-2022-40186 in the wild and no public exploit code.

## Other vulnerabilities in Hashicorp Vault

- [CVE-2020-35192](https://insights.sbomify.com/CVE-2020-35192/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2020-12757](https://insights.sbomify.com/CVE-2020-12757/): Improper Input Validation in HashiCorp Vault (critical 9.8)
- [CVE-2025-6000](https://insights.sbomify.com/CVE-2025-6000/): Arbitrary Remote Code Execution via Plugin Catalog Abuse (critical 9.1)
- [CVE-2022-36129](https://insights.sbomify.com/CVE-2022-36129/): Missing authorization in n/a (critical 9.1)
- [CVE-2020-10661](https://insights.sbomify.com/CVE-2020-10661/): HashiCorp Vault Improper Privilege Management (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-40186 and fix it if it is affected.

What it is: CVE-2022-40186 is a critical missing authorization vulnerability in Hashicorp Vault, published on 22 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-40186 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/vault (Go): affected from 1.10.0; fixed in 1.10.6
- github.com/hashicorp/vault (Go): affected from 1.10.0; fixed in 1.10.6
- github.com/hashicorp/vault (Go): affected from 1.11.0; fixed in 1.11.3
- github.com/hashicorp/vault (Go): affected from 1.11.0; fixed in 1.11.3
- github.com/hashicorp/vault (Go): affected from 1.8.0; fixed in 1.9.9, 1.10.6, 1.11.3
- github.com/hashicorp/vault (Go): affected from 1.8.0; fixed in 1.9.9
- github.com/hashicorp/vault (Go): affected from 1.8.0; fixed in 1.9.9
- vault (Bitnami): affected from 1.8.0; fixed in 1.9.9, 1.10.6, 1.11.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-40186/ (Markdown: https://insights.sbomify.com/CVE-2022-40186/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-40186
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-40186
- OSV: https://osv.dev/vulnerability/CVE-2022-40186

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-40186/
Summaries are generated and may contain mistakes; the official description above is the record.
