CVE-2022-40189 Apache Airlfow Pig Provider RCE

Critical 9.8 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2022-40189?

CVE-2022-40189 is a critical vulnerability in Apache Airflow, published on 22 Nov 2022.

Official description

Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in Apache Airflow Pig Provider, Apache Airflow allows an attacker to control commands executed in the task execution context, without write access to DAG files. This issue affects Pig Provider versions prior to 4.0.0. It also impacts any Apache Airflow versions prior to 2.3.0 in case Pig Provider is installed (Pig Provider 4.0.0 can only be installed for Airflow 2.3.0+). Note that you need to manually install the Pig Provider version 4.0.0 in order to get rid of the vulnerability on top of Airflow 2.3.0+ version.

Weakness: CWE-78

Which versions are affected by CVE-2022-40189?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 2 products.

PackageAffectedFixed in
apache-airflow PyPIAll versions2.3.0
apache-airflow PyPIAll versions2.3.0
apache-airflow PyPIAll versions2.3.0
airflow BitnamiAll versions2.3.0

Products include Apache Airflow, Apache Apache-Airflow-Providers-Apache-Pig.

How do I fix CVE-2022-40189?

Upgrade apache-airflow to 2.3.0 or later.

Is CVE-2022-40189 being exploited?

There is no known exploitation of CVE-2022-40189 in the wild and no public exploit code.

All Apache Airflow vulnerabilities

Sources

Also known as BIT-airflow-2022-40189, GHSA-rmf2-pwfq-h75j, PYSEC-2026-270.

Is CVE-2022-40189 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free