CVE-2022-40208 Moodle may allow students to bypass sequential navigation during a quiz attempt
Students can bypass sequential navigation restrictions during quiz attempts in Moodle, undermining assessment integrity.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-40208?
CVE-2022-40208 is a medium-severity vulnerability in Moodle Moodle, published on 24 Mar 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
In Moodle, insufficient limitations in some quiz web services made it possible for students to bypass sequential navigation during a quiz attempt.
Weakness: CWE-285
Which versions are affected by CVE-2022-40208?
7 open source packages ship an affected version, including moodle/moodle and moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 3.9.16 |
moodle/moodle Packagist | All versions | 3.9.16 |
moodle/moodle Packagist | From 3.11.0 | 3.11.9 |
moodle/moodle Packagist | From 3.11.0 | 3.11.9 |
moodle/moodle Packagist | From 4.0.0 | 4.0.3 |
moodle/moodle Packagist | From 4.0.0 | 4.0.3 |
1 more packages
moodle Bitnami | From 3.9.0 | 3.9.16, 3.11.9, 4.0.3 |
Products include Moodle Moodle.
How do I fix CVE-2022-40208?
Upgrade moodle/moodle to a fixed version for your release line: 3.9.16, 3.11.9 or 4.0.3.
Is CVE-2022-40208 being exploited?
There is no known exploitation of CVE-2022-40208 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as BIT-moodle-2022-40208, GHSA-948f-j464-rfj2, UBUNTU-CVE-2022-40208.