CVE-2022-4037 Race condition in GitLab

Medium 6.4 Published Updated

A race condition in GitLab allows attackers to forge verified emails and take over third-party accounts when GitLab acts as an OAuth provider.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-4037?

CVE-2022-4037 is a medium-severity vulnerability in Gitlab Gitlab, published on 12 Jan 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

An issue has been discovered in GitLab CE/EE affecting all versions before 15.5.7, all versions starting from 15.6 before 15.6.4, all versions starting from 15.7 before 15.7.2. A race condition can lead to verified email forgery and takeover of third-party accounts when using GitLab as an OAuth provider.

Weakness: CWE-362

Which versions are affected by CVE-2022-4037?

1 open source package ship an affected version, including gitlab. It affects 1 product.

PackageAffectedFixed in
gitlab BitnamiAll versions15.5.7, 15.6.4, 15.7.2

Products include Gitlab Gitlab.

How do I fix CVE-2022-4037?

Upgrade gitlab to a fixed version for your release line: 15.5.7, 15.6.4 or 15.7.2.

Is CVE-2022-4037 being exploited?

There is no known exploitation of CVE-2022-4037 in the wild and no public exploit code.

All Gitlab Gitlab vulnerabilities

Sources

Also known as BIT-gitlab-2022-4037, GHSA-8r38-jrwh-8grw, UBUNTU-CVE-2022-4037.

Is CVE-2022-4037 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free