# CVE-2022-40489: ThinkCMF Cross Site Request Forgery (CSRF) vulnerability

> A CSRF vulnerability in ThinkCMF allows attackers to inject a Super Administrator user, leading to privilege escalation and account takeover.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Dec 2022
- **Updated:** 24 Apr 2025
- **Also known as:** GHSA-6xw3-cpqj-8mxr

## What is CVE-2022-40489?

CVE-2022-40489 is a high-severity vulnerability in n/a, published on 1 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

ThinkCMF version 6.0.7 is affected by a Cross Site Request Forgery (CSRF) vulnerability that allows a Super Administrator user to be injected into administrative users.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2022-40489?

2 open source packages ship an affected version, including thinkcmf/thinkcmf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `thinkcmf/thinkcmf` | Packagist | All versions | 6.0.8 |
| `thinkcmf/thinkcmf` | Packagist | All versions | 6.0.8 |

Products: Thinkcmf Thinkcmf.

## How do I fix CVE-2022-40489?

Upgrade thinkcmf/thinkcmf to 6.0.8 or later.

## Is CVE-2022-40489 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-40489 exists.

## Other vulnerabilities in n/a

- [CVE-2024-31615](https://insights.sbomify.com/CVE-2024-31615/): File upload in n/a (critical 9.8)
- [CVE-2020-20601](https://insights.sbomify.com/CVE-2020-20601/): Code injection in n/a (critical 9.8)
- [CVE-2019-6713](https://insights.sbomify.com/CVE-2019-6713/): Code injection in n/a (critical 9.8)
- [CVE-2019-7580](https://insights.sbomify.com/CVE-2019-7580/): Code injection in n/a (high 8.8)
- [CVE-2018-19898](https://insights.sbomify.com/CVE-2018-19898/): SQL injection in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-40489 and fix it if it is affected.

What it is: CVE-2022-40489 is a high-severity vulnerability in n/a, published on 1 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-40489 exists.

Affected packages and fixed versions:
- thinkcmf/thinkcmf (Packagist): affected all versions; fixed in 6.0.8
- thinkcmf/thinkcmf (Packagist): affected all versions; fixed in 6.0.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-40489/ (Markdown: https://insights.sbomify.com/CVE-2022-40489/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-40489
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-40489
- OSV: https://osv.dev/vulnerability/CVE-2022-40489

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-40489/
Summaries are generated and may contain mistakes; the official description above is the record.
