CVE-2022-40604 Format String Vulnerability
Attackers can extract sensitive information via a format string vulnerability in Apache Airflow URLs.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-40604?
CVE-2022-40604 is a high-severity vulnerability in Apache Airflow, published on 21 Sep 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In Apache Airflow 2.3.0 through 2.3.4, part of a url was unnecessarily formatted, allowing for possible information extraction.
Weakness: CWE-134
Which versions are affected by CVE-2022-40604?
4 open source packages ship an affected version, including apache-airflow and airflow. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apache-airflow PyPI | From 2.3.0 | 2.4.0b1 |
apache-airflow PyPI | From 2.3.0 | 2.4.0rc1 |
apache-airflow PyPI | From 2.3.0 | 2.4.0rc1 |
airflow Bitnami | From 2.3.0 | 2.3.5 |
Products include Apache Airflow.
How do I fix CVE-2022-40604?
Upgrade apache-airflow to a fixed version for your release line: 2.4.0b1 or 2.4.0rc1.
Is CVE-2022-40604 being exploited?
There is no known exploitation of CVE-2022-40604 in the wild and no public exploit code.
Other vulnerabilities in Apache Airflow
- CVE-2020-13927 Apache Airflow's Experimental API Authentication Bypass
- CVE-2020-11978 Apache Airflow Command Injection
- CVE-2026-33264 Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize()
- CVE-2023-25754 Apache Airflow: Privilege escalation using airflow logs
- CVE-2023-22884 Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow
Sources
Also known as BIT-airflow-2022-40604, GHSA-5rp4-749p-vx26, PYSEC-2022-279.