{"answers":{"affected":"2 open source packages ship an affected version, including dalli. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-4064 exists.","fix":"Upgrade dalli to 3.2.3 or later.","what":"CVE-2022-4064 is a medium-severity code injection vulnerability in Dalli, published on 19 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-4064 and fix it if it is affected.\n\nWhat it is: CVE-2022-4064 is a medium-severity code injection vulnerability in Dalli, published on 19 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-4064 exists.\n\nAffected packages and fixed versions:\n- dalli (RubyGems): affected all versions; fixed in 3.2.3\n- dalli (RubyGems): affected all versions; fixed in 3.2.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-4064/ (Markdown: https://insights.sbomify.com/CVE-2022-4064/index.md)","id":"CVE-2022-4064","markdown":"https://insights.sbomify.com/CVE-2022-4064/index.md","name":"CVE-2022-4064","record":{"aliases":["GHSA-3xg8-cc8f-9wv2","OESA-2023-1002","UBUNTU-CVE-2022-4064"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby memcached client","requires_auth":"none","summary":"Attackers can inject code via the meta_set function in the Dalli Ruby memcached client, potentially leading to remote code execution.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[{"product":"dalli","vendor":"dalli_project"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"},{"id":"CWE-707","name":"Improper Neutralization"}],"description":"A vulnerability was found in Dalli up to 3.2.2. It has been classified as problematic. Affected is the function self.meta_set of the file lib/dalli/protocol/meta/request_formatter.rb of the component Meta Protocol Handler. The manipulation of the argument cas/ttl leads to injection. It is possible to launch the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 3.2.3 is able to address this issue. The patch is identified as 48d594dae55934476fec61789e7a7c3700e0f50d. It is recommended to upgrade the affected component.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Dalli Meta Protocol request_formatter.rb self.meta_set injection","id":"CVE-2022-4064","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"code_injection","year":"2022"},"n_packages":2,"n_references":7,"next":{"headline":"cbeust testng XML File Parser JarFileUtils.java testngXmlExistsInJar path traversal","id":"CVE-2022-4065"},"packages":[{"ecosystem":"RubyGems","fixed":["3.2.3"],"introduced":["0"],"last_affected":[],"package":"dalli","purl":null,"source":"GHSA-3xg8-cc8f-9wv2"},{"ecosystem":"RubyGems","fixed":["3.2.3"],"introduced":["0"],"last_affected":[],"package":"dalli","purl":"pkg:gem/dalli","source":"GHSA-3xg8-cc8f-9wv2"}],"prev":{"headline":"InPost Gallery \u003c 2.1.4.1 - Unauthenticated LFI to RCE","id":"CVE-2022-4063"},"products":["Dalli"],"published":"2022-11-19","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-15","vendors":["n/a"]},"summary":"Attackers can inject code via the meta_set function in the Dalli Ruby memcached client, potentially leading to remote code execution.","url":"https://insights.sbomify.com/CVE-2022-4064/"}