# CVE-2022-4064: Dalli Meta Protocol request_formatter.rb self.meta_set injection

> Attackers can inject code via the meta_set function in the Dalli Ruby memcached client, potentially leading to remote code execution.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Nov 2022
- **Updated:** 15 Apr 2025
- **Also known as:** GHSA-3xg8-cc8f-9wv2, OESA-2023-1002, UBUNTU-CVE-2022-4064

## What is CVE-2022-4064?

CVE-2022-4064 is a medium-severity code injection vulnerability in Dalli, published on 19 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability was found in Dalli up to 3.2.2. It has been classified as problematic. Affected is the function self.meta_set of the file lib/dalli/protocol/meta/request_formatter.rb of the component Meta Protocol Handler. The manipulation of the argument cas/ttl leads to injection. It is possible to launch the attack remotely. The complexity of an attack is rather high. The exploitability is told to be difficult. The exploit has been disclosed to the public and may be used. Upgrading to version 3.2.3 is able to address this issue. The patch is identified as 48d594dae55934476fec61789e7a7c3700e0f50d. It is recommended to upgrade the affected component.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component), CWE-707 (Improper Neutralization)

## Which versions are affected by CVE-2022-4064?

2 open source packages ship an affected version, including dalli. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dalli` | RubyGems | All versions | 3.2.3 |
| `dalli` | RubyGems | All versions | 3.2.3 |

Products: Dalli Project Dalli.

## How do I fix CVE-2022-4064?

Upgrade dalli to 3.2.3 or later.

## Is CVE-2022-4064 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-4064 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-4064 and fix it if it is affected.

What it is: CVE-2022-4064 is a medium-severity code injection vulnerability in Dalli, published on 19 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-4064 exists.

Affected packages and fixed versions:
- dalli (RubyGems): affected all versions; fixed in 3.2.3
- dalli (RubyGems): affected all versions; fixed in 3.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-4064/ (Markdown: https://insights.sbomify.com/CVE-2022-4064/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-4064
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-4064
- OSV: https://osv.dev/vulnerability/CVE-2022-4064

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-4064/
Summaries are generated and may contain mistakes; the official description above is the record.
