# CVE-2022-40664: Authentication Bypass Vulnerability in Shiro when forwarding or including via RequestDispatcher


- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 12 Oct 2022
- **Updated:** 15 May 2025
- **Also known as:** DEBIAN-CVE-2022-40664, GHSA-45x9-q6vj-cqgq, UBUNTU-CVE-2022-40664

## What is CVE-2022-40664?

CVE-2022-40664 is a critical vulnerability in Apache Shiro, published on 12 Oct 2022. 

### Official description

Apache Shiro before 1.10.0, Authentication Bypass Vulnerability in Shiro when forwarding or including via RequestDispatcher.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2022-40664?

2 open source packages ship an affected version, including org.apache.shiro:shiro-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.shiro:shiro-core` | Maven | All versions | 1.10.0 |
| `org.apache.shiro:shiro-core` | Maven | All versions | 1.10.0 |

Products: Apache Shiro.

## How do I fix CVE-2022-40664?

Upgrade org.apache.shiro:shiro-core to 1.10.0 or later.

## Is CVE-2022-40664 being exploited?

There is no known exploitation of CVE-2022-40664 in the wild and no public exploit code.

## Other vulnerabilities in Apache Shiro

- [CVE-2023-34478](https://insights.sbomify.com/CVE-2023-34478/): Path Traversal in Apache Shiro (critical 9.8)
- [CVE-2022-32532](https://insights.sbomify.com/CVE-2022-32532/): Authentication Bypass Vulnerability (critical 9.8)
- [CVE-2021-41303](https://insights.sbomify.com/CVE-2021-41303/): Apache Shiro vulnerable to a specially crafted HTTP request causing an authentication bypass (critical 9.8)
- [CVE-2020-17523](https://insights.sbomify.com/CVE-2020-17523/): Authentication bypass in Apache Shiro (critical 9.8)
- [CVE-2020-17510](https://insights.sbomify.com/CVE-2020-17510/): Authentication bypass in Apache Shiro (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-40664 and fix it if it is affected.

What it is: CVE-2022-40664 is a critical vulnerability in Apache Shiro, published on 12 Oct 2022. 
Exploitation: There is no known exploitation of CVE-2022-40664 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.shiro:shiro-core (Maven): affected all versions; fixed in 1.10.0
- org.apache.shiro:shiro-core (Maven): affected all versions; fixed in 1.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-40664/ (Markdown: https://insights.sbomify.com/CVE-2022-40664/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-40664
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-40664
- OSV: https://osv.dev/vulnerability/CVE-2022-40664

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-40664/
Summaries are generated and may contain mistakes; the official description above is the record.
