CVE-2022-40716 HashiCorp Consul vulnerable to authorization bypass
Attackers with privileged access can bypass service mesh intentions by exploiting missing SAN URI validation in Consul's internal RPC endpoint.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-40716?
CVE-2022-40716 is a medium-severity vulnerability in n/a, published on 23 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
HashiCorp Consul and Consul Enterprise up to 1.11.8, 1.12.4, and 1.13.1 do not check for multiple SAN URI values in a CSR on the internal RPC endpoint, enabling leverage of privileged access to bypass service mesh intentions. Fixed in 1.11.9, 1.12.5, and 1.13.2."
Weakness: CWE-252
Which versions are affected by CVE-2022-40716?
8 open source packages ship an affected version, including github.com/hashicorp/consul and consul. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/hashicorp/consul Go | All versions | 1.11.9, 1.12.5, 1.13.2 |
github.com/hashicorp/consul Go | All versions | 1.11.9 |
github.com/hashicorp/consul Go | All versions | 1.11.9 |
github.com/hashicorp/consul Go | From 1.12.0 | 1.12.5 |
github.com/hashicorp/consul Go | From 1.12.0 | 1.12.5 |
github.com/hashicorp/consul Go | From 1.13.0 | 1.13.2 |
2 more packages
github.com/hashicorp/consul Go | From 1.13.0 | 1.13.2 |
consul Bitnami | All versions | 1.11.9, 1.12.5, 1.13.2 |
Products include Hashicorp Consul.
How do I fix CVE-2022-40716?
Upgrade github.com/hashicorp/consul to a fixed version for your release line: 1.11.9, 1.12.5 or 1.13.2.
Is CVE-2022-40716 being exploited?
There is no known exploitation of CVE-2022-40716 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2021-41805 Privilege escalation in n/a
- CVE-2021-37219 HashiCorp Consul Privilege Escalation Vulnerability
- CVE-2023-2816 Consul Envoy Extension Downsteam Proxy Configuration By Upstream Service Owner
- CVE-2024-10006 Consul L7 Intentions Vulnerable To Headers Bypass
- CVE-2024-10005 Consul L7 Intentions Vulnerable To URL Path Bypass
Sources
Also known as BIT-consul-2022-40716, DEBIAN-CVE-2022-40716, GHSA-m69r-9g56-7mv8, GO-2022-1029, UBUNTU-CVE-2022-40716.