# CVE-2022-40716: HashiCorp Consul vulnerable to authorization bypass

> Attackers with privileged access can bypass service mesh intentions by exploiting missing SAN URI validation in Consul's internal RPC endpoint.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Sep 2022
- **Updated:** 27 May 2025
- **Also known as:** BIT-consul-2022-40716, DEBIAN-CVE-2022-40716, GHSA-m69r-9g56-7mv8, GO-2022-1029, UBUNTU-CVE-2022-40716

## What is CVE-2022-40716?

CVE-2022-40716 is a medium-severity vulnerability in n/a, published on 23 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

HashiCorp Consul and Consul Enterprise up to 1.11.8, 1.12.4, and 1.13.1 do not check for multiple SAN URI values in a CSR on the internal RPC endpoint, enabling leverage of privileged access to bypass service mesh intentions. Fixed in 1.11.9, 1.12.5, and 1.13.2."

Weakness: CWE-252 (Unchecked Return Value)

## Which versions are affected by CVE-2022-40716?

8 open source packages ship an affected version, including github.com/hashicorp/consul and consul. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/consul` | Go | All versions | 1.11.9, 1.12.5, 1.13.2 |
| `github.com/hashicorp/consul` | Go | All versions | 1.11.9 |
| `github.com/hashicorp/consul` | Go | All versions | 1.11.9 |
| `github.com/hashicorp/consul` | Go | From 1.12.0 | 1.12.5 |
| `github.com/hashicorp/consul` | Go | From 1.12.0 | 1.12.5 |
| `github.com/hashicorp/consul` | Go | From 1.13.0 | 1.13.2 |
| `github.com/hashicorp/consul` | Go | From 1.13.0 | 1.13.2 |
| `consul` | Bitnami | All versions | 1.11.9, 1.12.5, 1.13.2 |

Products: Hashicorp Consul.

## How do I fix CVE-2022-40716?

Upgrade github.com/hashicorp/consul to a fixed version for your release line: 1.11.9, 1.12.5 or 1.13.2.

## Is CVE-2022-40716 being exploited?

There is no known exploitation of CVE-2022-40716 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-41805](https://insights.sbomify.com/CVE-2021-41805/): Privilege escalation in n/a (high 8.8)
- [CVE-2021-37219](https://insights.sbomify.com/CVE-2021-37219/): HashiCorp Consul Privilege Escalation Vulnerability (high 8.8)
- [CVE-2023-2816](https://insights.sbomify.com/CVE-2023-2816/): Consul Envoy Extension Downsteam Proxy Configuration By Upstream Service Owner (high 8.7)
- [CVE-2024-10006](https://insights.sbomify.com/CVE-2024-10006/): Consul L7 Intentions Vulnerable To Headers Bypass (high 8.3)
- [CVE-2024-10005](https://insights.sbomify.com/CVE-2024-10005/): Consul L7 Intentions Vulnerable To URL Path Bypass (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-40716 and fix it if it is affected.

What it is: CVE-2022-40716 is a medium-severity vulnerability in n/a, published on 23 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-40716 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/consul (Go): affected all versions; fixed in 1.11.9, 1.12.5, 1.13.2
- github.com/hashicorp/consul (Go): affected all versions; fixed in 1.11.9
- github.com/hashicorp/consul (Go): affected all versions; fixed in 1.11.9
- github.com/hashicorp/consul (Go): affected from 1.12.0; fixed in 1.12.5
- github.com/hashicorp/consul (Go): affected from 1.12.0; fixed in 1.12.5
- github.com/hashicorp/consul (Go): affected from 1.13.0; fixed in 1.13.2
- github.com/hashicorp/consul (Go): affected from 1.13.0; fixed in 1.13.2
- consul (Bitnami): affected all versions; fixed in 1.11.9, 1.12.5, 1.13.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-40716/ (Markdown: https://insights.sbomify.com/CVE-2022-40716/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-40716
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-40716
- OSV: https://osv.dev/vulnerability/CVE-2022-40716

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-40716/
Summaries are generated and may contain mistakes; the official description above is the record.
