CVE-2022-40743 Apache Traffic Server: Security issues with the xdebug plugin
Improper input validation in the xdebug plugin allows attackers to perform cross-site scripting and cache poisoning attacks.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-40743?
CVE-2022-40743 is a medium-severity cross-site scripting vulnerability in Apache Traffic Server, published on 19 Dec 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Improper Input Validation vulnerability for the xdebug plugin in Apache Software Foundation Apache Traffic Server can lead to cross site scripting and cache poisoning attacks.This issue affects Apache Traffic Server: 9.0.0 to 9.1.3. Users should upgrade to 9.1.4 or later versions.
Weakness: CWE-79
Which versions are affected by CVE-2022-40743?
It affects 1 product.
Products include Apache Traffic Server.
How do I fix CVE-2022-40743?
Upgrade to a fixed version.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2022-40743 being exploited?
There is no known exploitation of CVE-2022-40743 in the wild and no public exploit code.
Other vulnerabilities in Apache Traffic Server
Sources
Also known as DEBIAN-CVE-2022-40743, GHSA-q99x-rwh5-433q, UBUNTU-CVE-2022-40743.