{"answers":{"affected":"4 open source packages ship an affected version, including snyk and snyk-go-plugin. It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-40764 in the wild and no public exploit code.","fix":"Upgrade snyk to 1.996.0 or later.","what":"CVE-2022-40764 is a high-severity command injection vulnerability in n/a, published on 3 Oct 2022. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-40764 and fix it if it is affected.\n\nWhat it is: CVE-2022-40764 is a high-severity command injection vulnerability in n/a, published on 3 Oct 2022. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-40764 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- snyk (npm): affected all versions; fixed in 1.996.0\n- snyk (npm): affected all versions; fixed in 1.996.0\n- snyk-go-plugin (npm): affected all versions; fixed in 1.19.1\n- snyk-go-plugin (npm): affected all versions; fixed in 1.19.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-40764/ (Markdown: https://insights.sbomify.com/CVE-2022-40764/index.md)","id":"CVE-2022-40764","markdown":"https://insights.sbomify.com/CVE-2022-40764/index.md","name":"CVE-2022-40764","record":{"aliases":["GHSA-hpqj-7cj6-hfj8"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Snyk CLI","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary commands via malicious files viewed in IDEs using vulnerable Snyk CLI plugins or packages.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"cli","vendor":"snyk"},{"product":"golang_cli","vendor":"snyk"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"Snyk CLI before 1.996.0 allows arbitrary command execution, affecting Snyk IDE plugins and the snyk npm package. Exploitation could follow from the common practice of viewing untrusted files in the Visual Studio Code editor, for example. The original demonstration was with shell metacharacters in the vendor.json ignore field, affecting snyk-go-plugin before 1.19.1. This affects, for example, the Snyk TeamCity plugin (which does not update automatically) before 20220930.142957.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Snyk CLI affected by Command Injection vulnerability","id":"CVE-2022-40764","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"command_injection","year":"2022"},"n_packages":4,"n_references":4,"next":{"headline":"Mitel MiVoice Connect Command Injection","id":"CVE-2022-40765"},"packages":[{"ecosystem":"npm","fixed":["1.996.0"],"introduced":["0"],"last_affected":[],"package":"snyk","purl":null,"source":"GHSA-hpqj-7cj6-hfj8"},{"ecosystem":"npm","fixed":["1.996.0"],"introduced":["0"],"last_affected":[],"package":"snyk","purl":"pkg:npm/snyk","source":"GHSA-hpqj-7cj6-hfj8"},{"ecosystem":"npm","fixed":["1.19.1"],"introduced":["0"],"last_affected":[],"package":"snyk-go-plugin","purl":null,"source":"GHSA-hpqj-7cj6-hfj8"},{"ecosystem":"npm","fixed":["1.19.1"],"introduced":["0"],"last_affected":[],"package":"snyk-go-plugin","purl":"pkg:npm/snyk-go-plugin","source":"GHSA-hpqj-7cj6-hfj8"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2022-40762"},"products":["n/a"],"published":"2022-10-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-03","vendors":["n/a"]},"summary":"Attackers can execute arbitrary commands via malicious files viewed in IDEs using vulnerable Snyk CLI plugins or packages.","url":"https://insights.sbomify.com/CVE-2022-40764/"}