# CVE-2022-40764: Snyk CLI affected by Command Injection vulnerability

> Attackers can execute arbitrary commands via malicious files viewed in IDEs using vulnerable Snyk CLI plugins or packages.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Oct 2022
- **Updated:** 3 Aug 2024
- **Also known as:** GHSA-hpqj-7cj6-hfj8

## What is CVE-2022-40764?

CVE-2022-40764 is a high-severity command injection vulnerability in n/a, published on 3 Oct 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Snyk CLI before 1.996.0 allows arbitrary command execution, affecting Snyk IDE plugins and the snyk npm package. Exploitation could follow from the common practice of viewing untrusted files in the Visual Studio Code editor, for example. The original demonstration was with shell metacharacters in the vendor.json ignore field, affecting snyk-go-plugin before 1.19.1. This affects, for example, the Snyk TeamCity plugin (which does not update automatically) before 20220930.142957.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2022-40764?

4 open source packages ship an affected version, including snyk and snyk-go-plugin. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `snyk` | npm | All versions | 1.996.0 |
| `snyk` | npm | All versions | 1.996.0 |
| `snyk-go-plugin` | npm | All versions | 1.19.1 |
| `snyk-go-plugin` | npm | All versions | 1.19.1 |

Products: Snyk Cli, Snyk Golang Cli.

## How do I fix CVE-2022-40764?

Upgrade snyk to 1.996.0 or later.

## Is CVE-2022-40764 being exploited?

There is no known exploitation of CVE-2022-40764 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-40764 and fix it if it is affected.

What it is: CVE-2022-40764 is a high-severity command injection vulnerability in n/a, published on 3 Oct 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-40764 in the wild and no public exploit code.

Affected packages and fixed versions:
- snyk (npm): affected all versions; fixed in 1.996.0
- snyk (npm): affected all versions; fixed in 1.996.0
- snyk-go-plugin (npm): affected all versions; fixed in 1.19.1
- snyk-go-plugin (npm): affected all versions; fixed in 1.19.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-40764/ (Markdown: https://insights.sbomify.com/CVE-2022-40764/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-40764
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-40764
- OSV: https://osv.dev/vulnerability/CVE-2022-40764

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-40764/
Summaries are generated and may contain mistakes; the official description above is the record.
