CVE-2022-40826 SQL injection in n/a

Critical 9.8 Published Updated

SQL injection vulnerability in CodeIgniter's or_having function allows attackers to manipulate database queries, though disputed by third parties.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-40826?

CVE-2022-40826 is a critical SQL injection vulnerability in n/a, published on 7 Oct 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

B.C. Institute of Technology CodeIgniter <=3.1.13 is vulnerable to SQL Injection via system\database\DB_query_builder.php or_having() function. Note: Multiple third parties have disputed this as not a valid vulnerability.

Weakness: CWE-89

Which versions are affected by CVE-2022-40826?

1 open source package ship an affected version, including codeigniter. It affects 1 product.

PackageAffectedFixed in
codeigniter BitnamiFrom 3.0.0 to 3.0.03.1.13

Products include Codeigniter Codeigniter.

How do I fix CVE-2022-40826?

Upgrade codeigniter to 3.1.13 or later.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2022-40826 being exploited?

There is no known exploitation of CVE-2022-40826 in the wild and no public exploit code.

Sources

Also known as BIT-codeigniter-2022-40826, GHSA-cjcg-hc25-x29f.

Is CVE-2022-40826 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free