# CVE-2022-40896: Pygments vulnerable to ReDoS

> Attackers can cause denial of service in applications using Pygments via a ReDoS vulnerability in the Smithy lexer.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Jul 2023
- **Updated:** 27 Nov 2024
- **Also known as:** AZL-27502, AZL-35139, DEBIAN-CVE-2022-40896, GHSA-mrwq-x4v8-fh7p, MGASA-2024-0107, MINI-pvx8-36jq-fh6r, OESA-2023-1477, OESA-2023-1478, OESA-2023-1479, PYSEC-2023-117, ROOT-APP-PYPI-CVE-2022-40896, UBUNTU-CVE-2022-40896, USN-7128-1

## What is CVE-2022-40896?

CVE-2022-40896 is a medium-severity denial of service vulnerability in n/a, published on 19 Jul 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

A ReDoS issue was discovered in pygments/lexers/smithy.py in pygments through 2.15.0 via SmithyLexer.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2022-40896?

3 open source packages ship an affected version, including pygments and Pygments. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pygments` | PyPI | All versions | 2.15.0 |
| `pygments` | PyPI | All versions | 2.15.1 |
| `Pygments` | PyPI | All versions | 2.15.0 |

Products: Pygments Pygments.

## How do I fix CVE-2022-40896?

Upgrade pygments to a fixed version for your release line: 2.15.0 or 2.15.1.

## Is CVE-2022-40896 being exploited?

There is no known exploitation of CVE-2022-40896 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-40896 and fix it if it is affected.

What it is: CVE-2022-40896 is a medium-severity denial of service vulnerability in n/a, published on 19 Jul 2023. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-40896 in the wild and no public exploit code.

Affected packages and fixed versions:
- pygments (PyPI): affected all versions; fixed in 2.15.0
- pygments (PyPI): affected all versions; fixed in 2.15.1
- Pygments (PyPI): affected all versions; fixed in 2.15.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-40896/ (Markdown: https://insights.sbomify.com/CVE-2022-40896/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-40896
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-40896
- OSV: https://osv.dev/vulnerability/CVE-2022-40896

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-40896/
Summaries are generated and may contain mistakes; the official description above is the record.
