CVE-2022-4093 SQL Injection in dolibarr/dolibarr
SQL injection in Dolibarr allows attackers to access sensitive data and potentially escalate privileges.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-4093?
CVE-2022-4093 is a high-severity SQL injection vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 21 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
SQL injection attacks can result in unauthorized access to sensitive data, such as passwords, credit card details, or personal user information. Many high-profile data breaches in recent years have been the result of SQL injection attacks, leading to reputational damage and regulatory fines. In some cases, an attacker can obtain a persistent backdoor into an organization's systems, leading to a long-term compromise that can go unnoticed for an extended period. This affect 16.0.1 and 16.0.2 only. 16.0.0 or lower, and 16.0.3 or higher are not affected
Weakness: CWE-89
Which versions are affected by CVE-2022-4093?
3 open source packages ship an affected version, including dolibarr/dolibarr and dolibarr. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
dolibarr/dolibarr Packagist | From 16.0.1 | 16.0.3 |
dolibarr/dolibarr Packagist | From 16.0.1 | 16.0.3 |
dolibarr Bitnami | From 16.0.1 to 16.0.1 | None |
Products include Dolibarr Dolibarr Erp\/Crm.
How do I fix CVE-2022-4093?
Upgrade dolibarr/dolibarr to 16.0.3 or later.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2022-4093 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-4093 exists.
Other vulnerabilities in Dolibarr Dolibarr Erp\/Crm
Sources
Also known as BIT-dolibarr-2022-4093, GHSA-gjg7-qfvp-9hm4, UBUNTU-CVE-2022-4093.