# CVE-2022-4093: SQL Injection in dolibarr/dolibarr

> SQL injection in Dolibarr allows attackers to access sensitive data and potentially escalate privileges.

- **Severity:** High 8.1 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Nov 2022
- **Updated:** 14 Apr 2025
- **Also known as:** BIT-dolibarr-2022-4093, GHSA-gjg7-qfvp-9hm4, UBUNTU-CVE-2022-4093

## What is CVE-2022-4093?

CVE-2022-4093 is a high-severity SQL injection vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 21 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

SQL injection attacks can result in unauthorized access to sensitive data, such as passwords, credit card details, or personal user information. Many high-profile data breaches in recent years have been the result of SQL injection attacks, leading to reputational damage and regulatory fines. In some cases, an attacker can obtain a persistent backdoor into an organization's systems, leading to a long-term compromise that can go unnoticed for an extended period. This affect 16.0.1 and 16.0.2 only. 16.0.0 or lower, and 16.0.3 or higher are not affected

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2022-4093?

3 open source packages ship an affected version, including dolibarr/dolibarr and dolibarr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dolibarr/dolibarr` | Packagist | From 16.0.1 | 16.0.3 |
| `dolibarr/dolibarr` | Packagist | From 16.0.1 | 16.0.3 |
| `dolibarr` | Bitnami | From 16.0.1 to 16.0.1 | None |

Products: Dolibarr Dolibarr Erp\/Crm.

## How do I fix CVE-2022-4093?

Upgrade dolibarr/dolibarr to 16.0.3 or later.

## Is CVE-2022-4093 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-4093 exists.

## Other vulnerabilities in Dolibarr Dolibarr Erp\/Crm

- [CVE-2022-43138](https://insights.sbomify.com/CVE-2022-43138/): Dolibarr vulnerable to privilege escalation (critical 9.8)
- [CVE-2022-40871](https://insights.sbomify.com/CVE-2022-40871/): Dolibarr vulnerable to Eval Injection (critical 9.8)
- [CVE-2021-33816](https://insights.sbomify.com/CVE-2021-33816/): Dolibarr remote PHP code execution (critical 9.8)
- [CVE-2020-7995](https://insights.sbomify.com/CVE-2020-7995/): Dolibarr Improper Restriction of Excessive Authentication Attempts (critical 9.8)
- [CVE-2013-2091](https://insights.sbomify.com/CVE-2013-2091/): SQL injection in dolibarr (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-4093 and fix it if it is affected.

What it is: CVE-2022-4093 is a high-severity SQL injection vulnerability in Dolibarr Dolibarr Erp\/Crm, published on 21 Nov 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-4093 exists.

Affected packages and fixed versions:
- dolibarr/dolibarr (Packagist): affected from 16.0.1; fixed in 16.0.3
- dolibarr/dolibarr (Packagist): affected from 16.0.1; fixed in 16.0.3
- dolibarr (Bitnami): affected from 16.0.1 up to 16.0.1; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-4093/ (Markdown: https://insights.sbomify.com/CVE-2022-4093/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-4093
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-4093
- OSV: https://osv.dev/vulnerability/CVE-2022-4093

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-4093/
Summaries are generated and may contain mistakes; the official description above is the record.
