CVE-2022-40954 Apache Airflow Spark Provider RCE that bypass restrictions to read arbitrary files

Medium 5.5 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2022-40954?

CVE-2022-40954 is a medium-severity vulnerability in Apache Airflow, published on 22 Nov 2022.

Official description

Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in Apache Airflow Spark Provider, Apache Airflow allows an attacker to read arbtrary files in the task execution context, without write access to DAG files. This issue affects Spark Provider versions prior to 4.0.0. It also impacts any Apache Airflow versions prior to 2.3.0 in case Spark Provider is installed (Spark Provider 4.0.0 can only be installed for Airflow 2.3.0+). Note that you need to manually install the Spark Provider version 4.0.0 in order to get rid of the vulnerability on top of Airflow 2.3.0+ version that has lower version of the Spark Provider installed).

Weakness: CWE-78

Which versions are affected by CVE-2022-40954?

4 open source packages ship an affected version, including apache-airflow and airflow. It affects 2 products.

PackageAffectedFixed in
apache-airflow PyPIAll versions2.3.0
apache-airflow PyPIAll versions2.3.0
apache-airflow PyPIAll versions2.3.0
airflow BitnamiAll versions2.3.0

Products include Apache Airflow, Apache Apache-Airflow-Providers-Apache-Spark.

How do I fix CVE-2022-40954?

Upgrade apache-airflow to 2.3.0 or later.

Is CVE-2022-40954 being exploited?

There is no known exploitation of CVE-2022-40954 in the wild and no public exploit code.

All Apache Airflow vulnerabilities

Sources

Also known as BIT-airflow-2022-40954, GHSA-45r6-j3cc-6mxx, PYSEC-2026-770.

Is CVE-2022-40954 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free