# CVE-2022-4111: Improper Validation of Specified Quantity in Input in tooljet/tooljet

> A logged-in attacker can cause denial of service by uploading profile pictures exceeding the unrestricted size limit in ToolJet.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Nov 2022
- **Updated:** 24 Apr 2025
- **Also known as:** GHSA-hgp8-w8fj-r4cm

## What is CVE-2022-4111?

CVE-2022-4111 is a medium-severity denial of service vulnerability in tooljet/tooljet, published on 22 Nov 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Unrestricted file size limit can lead to DoS in tooljet/tooljet <1.27 by allowing a logged in attacker to upload profile pictures over 2MB.

Weakness: CWE-1284 (Improper Validation of Specified Quantity in Input)

## Which versions are affected by CVE-2022-4111?

2 open source packages ship an affected version, including tooljet. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tooljet` | npm | All versions | 1.27.0 |
| `tooljet` | npm | All versions | 1.27.0 |

Products: Tooljet Tooljet.

## How do I fix CVE-2022-4111?

Upgrade tooljet to 1.27.0 or later.

## Is CVE-2022-4111 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-4111 exists.

## Other vulnerabilities in tooljet/tooljet

- [CVE-2022-3422](https://insights.sbomify.com/CVE-2022-3422/): Improper Privilege Management in tooljet/tooljet (critical 9.8)
- [CVE-2022-2631](https://insights.sbomify.com/CVE-2022-2631/): Improper Access Control in tooljet/tooljet (critical 9.8)
- [CVE-2022-2037](https://insights.sbomify.com/CVE-2022-2037/): Excessive Attack Surface in tooljet/tooljet (critical 9.8)
- [CVE-2022-23067](https://insights.sbomify.com/CVE-2022-23067/): ToolJet - Token Leakage via Referer Header (high 8.8)
- [CVE-2022-27978](https://insights.sbomify.com/CVE-2022-27978/): Business logic in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-4111 and fix it if it is affected.

What it is: CVE-2022-4111 is a medium-severity denial of service vulnerability in tooljet/tooljet, published on 22 Nov 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-4111 exists.

Affected packages and fixed versions:
- tooljet (npm): affected all versions; fixed in 1.27.0
- tooljet (npm): affected all versions; fixed in 1.27.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-4111/ (Markdown: https://insights.sbomify.com/CVE-2022-4111/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-4111
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-4111
- OSV: https://osv.dev/vulnerability/CVE-2022-4111

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-4111/
Summaries are generated and may contain mistakes; the official description above is the record.
