{"answers":{"affected":"4 open source packages ship an affected version, including apache-airflow-providers-apache-hive and airflow. It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-41131 in the wild and no public exploit code.","fix":"Upgrade apache-airflow-providers-apache-hive to 4.1.0 or later.","what":"CVE-2022-41131 is a high-severity command injection vulnerability in Apache Airflow, published on 22 Nov 2022. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-41131 and fix it if it is affected.\n\nWhat it is: CVE-2022-41131 is a high-severity command injection vulnerability in Apache Airflow, published on 22 Nov 2022. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-41131 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- apache-airflow-providers-apache-hive (PyPI): affected all versions; fixed in 4.1.0\n- apache-airflow-providers-apache-hive (PyPI): affected all versions; fixed in 4.1.0\n- apache-airflow-providers-apache-hive (PyPI): affected all versions; fixed in 4.1.0\n- airflow (Bitnami): affected all versions; fixed in 2.3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-41131/ (Markdown: https://insights.sbomify.com/CVE-2022-41131/index.md)","id":"CVE-2022-41131","markdown":"https://insights.sbomify.com/CVE-2022-41131/index.md","name":"CVE-2022-41131","record":{"aliases":["BIT-airflow-2022-41131","GHSA-cm43-f2pv-6v68","PYSEC-2026-772"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Apache Airflow Hive Provider","requires_auth":"low_privilege","summary":"Attackers can execute arbitrary OS commands in the task execution context via the Hive Provider connection, requiring an upgrade to the provider.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"airflow","vendor":"apache"},{"product":"apache-airflow-providers-apache-hive","vendor":"apache"}],"cvss":{"score":7.8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability in Apache Airflow Hive Provider, Apache Airflow allows an attacker to execute arbtrary commands in the task execution context, without write access to DAG files. This issue affects Hive Provider versions prior to 4.1.0. It also impacts any Apache Airflow versions prior to 2.3.0 in case HIve Provider is installed (Hive Provider 4.1.0 can only be installed for Airflow 2.3.0+). Note that you need to manually install the HIve Provider version 4.1.0 in order to get rid of the vulnerability on top of Airflow 2.3.0+ version that has lower version of the Hive Provider installed).","ecosystems":["Bitnami","PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Airflow Hive Provider vulnerability (command injection via hive_cli connection)","id":"CVE-2022-41131","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":"apache:airflow","products":["apache:airflow"],"type":"command_injection","year":"2022"},"n_packages":4,"n_references":2,"next":{"headline":"WordPress Ezoic plugin \u003c= 2.8.8 - Unauthenticated Plugin Settings Change Leading To Stored XSS Vulnerability","id":"CVE-2022-41132"},"packages":[{"ecosystem":"Bitnami","fixed":["2.3.0"],"introduced":["0"],"last_affected":[],"package":"airflow","purl":"pkg:bitnami/airflow","source":"BIT-airflow-2022-41131"},{"ecosystem":"PyPI","fixed":["4.1.0"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-apache-hive","purl":null,"source":"GHSA-cm43-f2pv-6v68"},{"ecosystem":"PyPI","fixed":["4.1.0"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-apache-hive","purl":"pkg:pypi/apache-airflow-providers-apache-hive","source":"GHSA-cm43-f2pv-6v68"},{"ecosystem":"PyPI","fixed":["4.1.0"],"introduced":["0"],"last_affected":[],"package":"apache-airflow-providers-apache-hive","purl":"pkg:pypi/apache-airflow-providers-apache-hive","source":"PYSEC-2026-772"}],"prev":{"headline":"Microsoft Windows Scripting Languages Remote Code Execution","id":"CVE-2022-41128"},"products":["Apache Airflow","Apache Airflow Hive Provider"],"published":"2022-11-22","related":[{"cvss_score":9.8,"headline":"Apache Airflow's Experimental API Authentication Bypass","id":"CVE-2020-13927","kev_date_added":"2022-01-18","published":"2020-11-10"},{"cvss_score":8.8,"headline":"Apache Airflow Command Injection","id":"CVE-2020-11978","kev_date_added":"2022-01-18","published":"2020-07-16"},{"cvss_score":9.8,"headline":"Apache Airflow: DAG author RCE on webserver via unrestricted import_string() in BaseSerialization.deserialize()","id":"CVE-2026-33264","kev_date_added":null,"published":"2026-07-07"},{"cvss_score":9.8,"headline":"Apache Airflow: Privilege escalation using airflow logs","id":"CVE-2023-25754","kev_date_added":null,"published":"2023-05-08"},{"cvss_score":9.8,"headline":"Apache Airflow, Apache Airflow MySQL Provider: Arbitrary file read via MySQL provider in Apache Airflow","id":"CVE-2023-22884","kev_date_added":null,"published":"2023-01-21"},{"cvss_score":9.8,"headline":"Apache Airflow Pinot provider allowed Command Injection","id":"CVE-2022-38649","kev_date_added":null,"published":"2022-11-22"},{"cvss_score":9.8,"headline":"Apache Airlfow Pig Provider RCE","id":"CVE-2022-40189","kev_date_added":null,"published":"2022-11-22"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-29","vendors":["Apache Software Foundation"]},"summary":"Attackers can execute arbitrary OS commands in the task execution context via the Hive Provider connection, requiring an upgrade to the provider.","url":"https://insights.sbomify.com/CVE-2022-41131/"}